summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-01-27 20:59:03 -0500
committerMike Gilbert <floppym@gentoo.org>2023-01-27 21:05:06 -0500
commitbc22069d1a41eeec6e22ba9bf391412a0244f5a7 (patch)
tree25e2c7d9f195e9453258c400da459081a0c159be
parentUpdate ChangeLog (diff)
downloadbaselayout-bc22069d1a41eeec6e22ba9bf391412a0244f5a7.tar.gz
baselayout-bc22069d1a41eeec6e22ba9bf391412a0244f5a7.tar.bz2
baselayout-bc22069d1a41eeec6e22ba9bf391412a0244f5a7.zip
Move /var/run and /var/lock back to the layout target
We need to ensure packages do not install things here and come up with a better migration plan. Bug: https://bugs.gentoo.org/648880 Bug: https://bugs.gentoo.org/892267 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index fb79cae9..3c8071c3 100644
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,7 @@
# It also has the added bonus of being easier to install on systems
# without an ebuild style package manager.
-PV = 2.11
+PV = 2.13
PKG = baselayout-$(PV)
DISTFILE = $(PKG).tar.bz2
@@ -60,17 +60,15 @@ install:
./make_os_release ${PV} > $(DESTDIR)/usr/lib/os-release
$(INSTALL_DIR) $(DESTDIR)/usr/share/baselayout
cp -pPR share/* $(DESTDIR)/usr/share/baselayout/
- # FHS compatibility symlinks
ln -snf ../proc/self/mounts $(DESTDIR)/etc/mtab
- $(INSTALL_DIR) $(DESTDIR)/var
- ln -snf ../run $(DESTDIR)/var/run
- ln -snf ../run/lock $(DESTDIR)/var/lock
layout:
# Create base filesytem layout
for x in $(KEEP_DIRS) ; do \
$(INSTALL_DIR) $(DESTDIR)$$x ; \
done
+ ln -snf ../run $(DESTDIR)/var/run
+ ln -snf ../run/lock $(DESTDIR)/var/lock
# Special dirs
chmod 0700 $(DESTDIR)/root
chmod 1777 $(DESTDIR)/var/tmp