aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meson.build2
-rw-r--r--src/libsystemd/meson.build6
-rw-r--r--src/systemctl/systemctl.c3
-rw-r--r--src/test/test-mountpoint-util.c18
-rw-r--r--src/udev/meson.build2
5 files changed, 21 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index b9b26cec2..1608278fb 100644
--- a/meson.build
+++ b/meson.build
@@ -3126,7 +3126,7 @@ if conf.get('ENABLE_EFI') == 1
if have_gnu_efi
status += [
'EFI machine type: @0@'.format(EFI_MACHINE_TYPE_NAME),
- 'EFI CC @0@'.format(efi_cc),
+ 'EFI CC @0@'.format(' '.join(efi_cc)),
'EFI lib directory: @0@'.format(efi_libdir),
'EFI lds directory: @0@'.format(efi_ldsdir),
'EFI include directory: @0@'.format(efi_incdir)]
diff --git a/src/libsystemd/meson.build b/src/libsystemd/meson.build
index 2576fe732..05d4ea0e7 100644
--- a/src/libsystemd/meson.build
+++ b/src/libsystemd/meson.build
@@ -6,7 +6,7 @@ id128_sources = files('''
sd-id128/sd-id128.c
'''.split())
-sd_daemon_c = files('sd-daemon/sd-daemon.c')
+sd_daemon_sources = files('sd-daemon/sd-daemon.c')
sd_event_sources = files('''
sd-event/event-source.h
@@ -15,7 +15,7 @@ sd_event_sources = files('''
sd-event/sd-event.c
'''.split())
-sd_login_c = files('sd-login/sd-login.c')
+sd_login_sources = files('sd-login/sd-login.c')
libsystemd_sources = files('''
sd-bus/bus-common-errors.c
@@ -91,7 +91,7 @@ libsystemd_sources = files('''
sd-resolve/resolve-private.h
sd-resolve/sd-resolve.c
sd-utf8/sd-utf8.c
-'''.split()) + id128_sources + sd_daemon_c + sd_event_sources + sd_login_c
+'''.split()) + id128_sources + sd_daemon_sources + sd_event_sources + sd_login_sources
disable_mempool_c = files('disable-mempool.c')
diff --git a/src/systemctl/systemctl.c b/src/systemctl/systemctl.c
index 9778ce62c..629f9cb50 100644
--- a/src/systemctl/systemctl.c
+++ b/src/systemctl/systemctl.c
@@ -6379,7 +6379,8 @@ static int enable_unit(int argc, char *argv[], void *userdata) {
if (carries_install_info == 0 && !ignore_carries_install_info)
log_notice("The unit files have no installation config (WantedBy=, RequiredBy=, Also=,\n"
"Alias= settings in the [Install] section, and DefaultInstance= for template\n"
- "units). This means they are not meant to be enabled using systemctl.\n \n"
+ "units). This means they are not meant to be enabled using systemctl.\n"
+ " \n" /* trick: the space is needed so that the line does not get stripped from output */
"Possible reasons for having this kind of units are:\n"
"%1$s A unit may be statically enabled by being symlinked from another unit's\n"
" .wants/ or .requires/ directory.\n"
diff --git a/src/test/test-mountpoint-util.c b/src/test/test-mountpoint-util.c
index 767a9fbbe..6d8bee0d6 100644
--- a/src/test/test-mountpoint-util.c
+++ b/src/test/test-mountpoint-util.c
@@ -18,6 +18,8 @@
static void test_mount_propagation_flags(const char *name, int ret, unsigned long expected) {
long unsigned flags;
+ log_info("/* %s(%s) */", __func__, name);
+
assert_se(mount_propagation_flags_from_string(name, &flags) == ret);
if (ret >= 0) {
@@ -41,6 +43,8 @@ static void test_mnt_id(void) {
void *k;
int r;
+ log_info("/* %s */", __func__);
+
assert_se(f = fopen("/proc/self/mountinfo", "re"));
assert_se(h = hashmap_new(&trivial_hash_ops));
@@ -55,6 +59,8 @@ static void test_mnt_id(void) {
assert_se(sscanf(line, "%i %*s %*s %*s %ms", &mnt_id, &path) == 2);
+ log_debug("mountinfo: %s → %i", path, mnt_id);
+
assert_se(hashmap_put(h, INT_TO_PTR(mnt_id), path) >= 0);
path = NULL;
}
@@ -68,14 +74,16 @@ static void test_mnt_id(void) {
continue;
}
- log_debug("mnt id of %s is %i\n", p, mnt_id2);
+ log_debug("mnt ids of %s are %i, %i\n", p, mnt_id, mnt_id2);
if (mnt_id == mnt_id2)
continue;
- /* The ids don't match? If so, then there are two mounts on the same path, let's check if that's really
- * the case */
- assert_se(path_equal_ptr(hashmap_get(h, INT_TO_PTR(mnt_id2)), p));
+ /* The ids don't match? If so, then there are two mounts on the same path, let's check if
+ * that's really the case */
+ char *t = hashmap_get(h, INT_TO_PTR(mnt_id2));
+ log_debug("the other path for mnt id %i is %s\n", mnt_id2, t);
+ assert_se(path_equal(p, t));
}
hashmap_free_free(h);
@@ -88,6 +96,8 @@ static void test_path_is_mount_point(void) {
_cleanup_free_ char *dir1 = NULL, *dir1file = NULL, *dirlink1 = NULL, *dirlink1file = NULL;
_cleanup_free_ char *dir2 = NULL, *dir2file = NULL;
+ log_info("/* %s */", __func__);
+
assert_se(path_is_mount_point("/", NULL, AT_SYMLINK_FOLLOW) > 0);
assert_se(path_is_mount_point("/", NULL, 0) > 0);
assert_se(path_is_mount_point("//", NULL, AT_SYMLINK_FOLLOW) > 0);
diff --git a/src/udev/meson.build b/src/udev/meson.build
index 53d65f99f..e378d9190 100644
--- a/src/udev/meson.build
+++ b/src/udev/meson.build
@@ -54,7 +54,7 @@ endif
if conf.get('HAVE_ACL') == 1
libudev_core_sources += ['udev-builtin-uaccess.c',
logind_acl_c,
- sd_login_c]
+ sd_login_sources]
endif
############################################################