aboutsummaryrefslogtreecommitdiff
path: root/hwdb
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-09-12 11:08:49 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-09-13 12:07:34 +0200
commit938be08926aa3c05faaca854776f29b9dab72661 (patch)
treed2f21973cf402e57fd37efefc46769981a719800 /hwdb
parentmeson: disable "slow tests" too when tests are generally disabled (diff)
downloadsystemd-938be08926aa3c05faaca854776f29b9dab72661.tar.gz
systemd-938be08926aa3c05faaca854776f29b9dab72661.tar.bz2
systemd-938be08926aa3c05faaca854776f29b9dab72661.zip
meson: disable _all_ tests when -Dtests=false
Back in 08318a2c5acb3d0e4243c36461e69a3e45482441, value "false" was enabled for '-Dtests=', but various tests were not conditionalized properly. So even with -Dtests=false -Dslow-tests=false we'd run 120 tests. Let's make this consistent.
Diffstat (limited to 'hwdb')
-rw-r--r--hwdb/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/hwdb/meson.build b/hwdb/meson.build
index 158292c71..31ee3e740 100644
--- a/hwdb/meson.build
+++ b/hwdb/meson.build
@@ -36,9 +36,11 @@ endif
############################################################
parse_hwdb_py = find_program('parse_hwdb.py')
-test('parse-hwdb',
- parse_hwdb_py,
- timeout : 90)
+if want_tests != 'false'
+ test('parse-hwdb',
+ parse_hwdb_py,
+ timeout : 90)
+endif
############################################################