aboutsummaryrefslogtreecommitdiff
path: root/sim/v850
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-01-03 21:40:34 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-03 22:07:39 -0500
commit77cf2ef5dc9099501529151921a73be904757466 (patch)
treeafe55fc45fb53886d73ed81e984f83222ab759a7 /sim/v850
parentsim: TODO: move to wiki (diff)
downloadbinutils-gdb-77cf2ef5dc9099501529151921a73be904757466.tar.gz
binutils-gdb-77cf2ef5dc9099501529151921a73be904757466.tar.bz2
binutils-gdb-77cf2ef5dc9099501529151921a73be904757466.zip
sim: parse_args: display getopt error ourselves
Fix a long standing todo where we let getopt write directly to stderr when an invalid option is passed. Use the sim io funcs instead as they go through the filtered callbacks that gdb wants.
Diffstat (limited to 'sim/v850')
-rw-r--r--sim/v850/ChangeLog4
-rw-r--r--sim/v850/interp.c4
2 files changed, 5 insertions, 3 deletions
diff --git a/sim/v850/ChangeLog b/sim/v850/ChangeLog
index 49b97c14a98..96ae98a9222 100644
--- a/sim/v850/ChangeLog
+++ b/sim/v850/ChangeLog
@@ -1,5 +1,9 @@
2016-01-03 Mike Frysinger <vapier@gentoo.org>
+ * interp.c (sim_open): Update sim_parse_args comment.
+
+2016-01-03 Mike Frysinger <vapier@gentoo.org>
+
* configure.ac (SIM_AC_OPTION_HOSTENDIAN): Delete.
* configure: Regenerate.
diff --git a/sim/v850/interp.c b/sim/v850/interp.c
index 422d926b2db..ef91d510e25 100644
--- a/sim/v850/interp.c
+++ b/sim/v850/interp.c
@@ -234,9 +234,7 @@ sim_open (SIM_OPEN_KIND kind,
/* similarly if in the internal RAM region */
sim_do_command (sd, "memory region 0xffe000,0x1000,1024");
- /* getopt will print the error message so we just have to exit if this fails.
- FIXME: Hmmm... in the case of gdb we need getopt to call
- print_filtered. */
+ /* The parser will print an error message for us, so we silently return. */
if (sim_parse_args (sd, argv) != SIM_RC_OK)
{
/* Uninstall the modules to avoid memory leaks,