summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-11-18 17:54:36 +0100
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-11-18 17:54:36 +0100
commit22565b10c77d25cb2db9421477a24088192c1201 (patch)
treea0ccae8f0c2f288433e3340e777d07ae944f5f10
parent[dev-vcs/hub] Initial import (diff)
downloadxarthisius-22565b10c77d25cb2db9421477a24088192c1201.tar.gz
xarthisius-22565b10c77d25cb2db9421477a24088192c1201.tar.bz2
xarthisius-22565b10c77d25cb2db9421477a24088192c1201.zip
Fix DESCRIPTION, drop useless deps that are needed for cucumber tests (disabled for now). Thanks to graaff for review
-rw-r--r--dev-vcs/hub/hub-1.10.2.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/dev-vcs/hub/hub-1.10.2.ebuild b/dev-vcs/hub/hub-1.10.2.ebuild
index 0d08a33..910a7b0 100644
--- a/dev-vcs/hub/hub-1.10.2.ebuild
+++ b/dev-vcs/hub/hub-1.10.2.ebuild
@@ -6,13 +6,12 @@ EAPI=4
USE_RUBY="ruby18 ruby19"
-RUBY_FAKEGEM_TASK_TEST="test"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
inherit ruby-fakegem
-DESCRIPTION="Wrapper for git that make working with GitHub easier"
+DESCRIPTION="Wrapper for git that makes working with GitHub easier"
HOMEPAGE="http://defunkt.io/hub"
SRC_URI="https://github.com/defunkt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -25,20 +24,16 @@ DEPEND=">=dev-vcs/git-1.7.3"
RDEPEND="${DEPEND}"
ruby_add_bdepend "test? (
- dev-ruby/test-unit
+ dev-ruby/test-unit:2
dev-ruby/webmock
)"
-ruby_add_rdepend "app-text/ronn
- dev-ruby/json
- dev-ruby/sinatra
- dev-util/aruba
- www-servers/thin"
-
-all_ruby_prepare() {
- # Remove bundler support.
- rm Gemfile || die
-}
+# There are optional cucumber tests that require
+# dev-ruby/json
+# dev-ruby/sinatra
+# dev-util/aruba
+# but lots of them fails. Disabled for now.
+# use RUBY_FAKEGEM_TASK_TEST="test features" to enable them
all_ruby_install() {
all_fakegem_install