summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/grub-scripts/grub-scripts-1.ebuild')
-rw-r--r--app-admin/grub-scripts/grub-scripts-1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/grub-scripts/grub-scripts-1.ebuild b/app-admin/grub-scripts/grub-scripts-1.ebuild
new file mode 100644
index 0000000..79cfec7
--- /dev/null
+++ b/app-admin/grub-scripts/grub-scripts-1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+#
+# Created by Wolfram Schlich <wschlich@gentoo.org>
+# Feedback is greatly appreciated!
+#
+
+IUSE=""
+DESCRIPTION="grub scripts"
+HOMEPAGE="http://dev.gentoo.org/~wschlich/"
+SRC_URI=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="sys-boot/grub"
+
+src_unpack() {
+ : NOP
+}
+
+src_compile() {
+ : NOP
+}
+
+src_install() {
+ doinitd "${FILESDIR}"/grub-set-default
+ dosbin "${FILESDIR}"/grub-md5-crypt.sh
+ dodoc "${FILESDIR}"/grub.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To set the grub default entry automagically on boot, you"
+ einfo "should now adjust /boot/grub/grub.conf (see the bundled"
+ einfo "grub.conf example for details) and add the 'grub-set-default'"
+ einfo "init script to the boot runlevel:"
+ einfo " rc-update add grub-set-default boot"
+ einfo
+}