summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2010-10-16 08:03:35 +0000
committerAndreas Proschofsky <suka@gentoo.org>2010-10-16 08:03:35 +0000
commit65b4ab445d29781718aae915f932fc0dad91c65e (patch)
treeaae6898a88129b668fc6ddfa49c38799d8fd6062
parentwhatever... (diff)
downloadsuka-65b4ab445d29781718aae915f932fc0dad91c65e.tar.gz
suka-65b4ab445d29781718aae915f932fc0dad91c65e.tar.bz2
suka-65b4ab445d29781718aae915f932fc0dad91c65e.zip
remove hacky old gtk-engines, add new one..
svn path=/; revision=264
-rw-r--r--x11-themes/gtk-engines/Manifest3
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.20.1-r5.ebuild43
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.91.1.ebuild39
3 files changed, 41 insertions, 44 deletions
diff --git a/x11-themes/gtk-engines/Manifest b/x11-themes/gtk-engines/Manifest
index f5c39cf..1002c6d 100644
--- a/x11-themes/gtk-engines/Manifest
+++ b/x11-themes/gtk-engines/Manifest
@@ -1 +1,2 @@
-EBUILD gtk-engines-2.20.1-r5.ebuild 1059 RMD160 a9b95cda2291edb702e4170e1050ce7449fc908e SHA1 37639dc9625502d75b871b476cc21b4d33179405 SHA256 d90b47a6b47a862c5340d210d748b4a1034286817a1a4eebf644423007369acb
+DIST gtk-engines-2.91.1.tar.bz2 592751 RMD160 92f46cfacec67c9fd1c7e4d40322a478c3d06827 SHA1 a280063068ad223561ab69c0346a133afe6bfa8e SHA256 e0ed144cdd298bc69b53face0e907369fb6a51f1eb333b5d04331f12758b454c
+EBUILD gtk-engines-2.91.1.ebuild 952 RMD160 5d5c6d0e9ac9e3051cd51597dd8980fc431a18fb SHA1 ec1b4eb6116511e6ba1b4d3229f556cad44e4e40 SHA256 f065c8b1b01af0d2e0456819352f6a9d271cb7272e9d8b51409b5848ac2defd0
diff --git a/x11-themes/gtk-engines/gtk-engines-2.20.1-r5.ebuild b/x11-themes/gtk-engines/gtk-engines-2.20.1-r5.ebuild
deleted file mode 100644
index c6b3deb..0000000
--- a/x11-themes/gtk-engines/gtk-engines-2.20.1-r5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-GCONF_DEBUG="no"
-
-inherit autotools git gnome2
-
-EGIT_REPO_URI="git://git.gnome.org/gtk-engines"
-EGIT_BRANCH="gnome3"
-EGIT_COMMIT="0d2b4ddb721531b56a16273e4cdfe6bcff45b75f"
-
-DESCRIPTION="GTK+2 standard engines and themes"
-HOMEPAGE="http://www.gtk.org/"
-SRC_URI=""
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="accessibility lua"
-
-RDEPEND=">=x11-libs/gtk+-2.12
- lua? ( dev-lang/lua )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.31
- >=dev-util/pkgconfig-0.9"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-pkg_setup() {
- G2CONF="${G2CONF} --enable-animation $(use_enable lua) $(use_with lua system-lua)"
- use accessibility || G2CONF="${G2CONF} --disable-hc"
- MAKEOPTS="-j1"
-}
-
-src_unpack() {
- git_src_unpack
-
- cd ${S}
- intltoolize --force --copy --automake || die
- eautoreconf
-}
diff --git a/x11-themes/gtk-engines/gtk-engines-2.91.1.ebuild b/x11-themes/gtk-engines/gtk-engines-2.91.1.ebuild
new file mode 100644
index 0000000..8c15a53
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.91.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.20.1-r1.ebuild,v 1.1 2010/06/13 16:16:22 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+DESCRIPTION="GTK+3 standard engines and themes"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="accessibility"
+
+RDEPEND=">=x11-libs/gtk+-2.90:3"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.31
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-animation $(use_enable accessibility hc)"
+}
+
+src_prepare() {
+ cd ${S}
+ ./autogen.sh
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ find "${D}" -name "*.la" -delete
+}