summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@redhat.com>2014-01-20 16:09:57 +0100
committerStanislav Ochotnicky <sochotnicky@redhat.com>2014-01-20 16:09:57 +0100
commitefc71e42ae2fb4e809a7759af25d357abc261e63 (patch)
treedde2f51846c71738372ef275b6d91f6b401d0cf1 /dev-util/rpmlint/rpmlint-1.5.ebuild
parentAdd dev-python/dpath (diff)
downloadsochotnicky-efc71e42ae2fb4e809a7759af25d357abc261e63.tar.gz
sochotnicky-efc71e42ae2fb4e809a7759af25d357abc261e63.tar.bz2
sochotnicky-efc71e42ae2fb4e809a7759af25d357abc261e63.zip
Add dev-util/rpmlint
Package-Manager: portage-2.2.7 Manifest-Sign-Key: 7B087241
Diffstat (limited to 'dev-util/rpmlint/rpmlint-1.5.ebuild')
-rw-r--r--dev-util/rpmlint/rpmlint-1.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/rpmlint/rpmlint-1.5.ebuild b/dev-util/rpmlint/rpmlint-1.5.ebuild
new file mode 100644
index 0000000..bdab286
--- /dev/null
+++ b/dev-util/rpmlint/rpmlint-1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mock/mock-1.0.3.ebuild,v 1.2 2011/11/02 22:44:19 vapier Exp $
+
+EAPI="5"
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Tool for checking common errors in RPM packages"
+HOMEPAGE="http://rpmlint.zarb.org/"
+SRC_URI="mirror://sourceforge/rpmlint/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion"
+
+DEPEND="app-arch/rpm[python]"
+RDEPEND="
+ app-arch/rpm[python]
+ sys-apps/file[python]
+ dev-python/pyenchant"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -r "${ED}"/usr/share/bash-completion || die
+ if use bash-completion;then
+ newbashcomp rpmlint.bash-completion ${PN}
+ newbashcomp rpmlint.bash-completion rpmdiff
+ fi
+}