summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-06-03 00:07:31 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-06-03 00:07:31 -0700
commitefbfb46d6ae4cdcb51f597ad22877466761bb027 (patch)
tree9e09f57edfab742b2bb57db7b39397ea7e843ba1 /games-util
parentNo ebuild changelog for us (diff)
downloadrobbat2-efbfb46d6ae4cdcb51f597ad22877466761bb027.tar.gz
robbat2-efbfb46d6ae4cdcb51f597ad22877466761bb027.tar.bz2
robbat2-efbfb46d6ae4cdcb51f597ad22877466761bb027.zip
Add my local stuff again.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/steam-installer/Manifest1
-rw-r--r--games-util/steam-installer/Manifest.old1
-rw-r--r--games-util/steam-installer/files/remove-ubuntu-specifics.patch39
-rw-r--r--games-util/steam-installer/steam-installer-9999.ebuild105
4 files changed, 146 insertions, 0 deletions
diff --git a/games-util/steam-installer/Manifest b/games-util/steam-installer/Manifest
new file mode 100644
index 0000000..9feedcd
--- /dev/null
+++ b/games-util/steam-installer/Manifest
@@ -0,0 +1 @@
+DIST steam.deb 2181162 SHA256 7db8eb1e561bb9e54ca1ee078d4ebd73eb5162626b0124d44cb91ff20423b0a2 SHA512 dce068ee05208a607a36a25abee84763a5614e92be042892f9c5525202e007ea24f52b84044af51881059e39d5f06a1df2e99a892243d154f5bbbeb2ba1cbd78 WHIRLPOOL aee50810ddde2192e957f6bc913b61c177ec17b1f13607af5d53afcd03b0165bae16de7fc2ec3a35b70aebaba76a104596ec4fb00e8ed8634e701c9630322e54
diff --git a/games-util/steam-installer/Manifest.old b/games-util/steam-installer/Manifest.old
new file mode 100644
index 0000000..6c476fd
--- /dev/null
+++ b/games-util/steam-installer/Manifest.old
@@ -0,0 +1 @@
+DIST steam.deb 1327544 SHA256 98df4be2c084cb0f1fabc3927f6987b15d2a9a19118f329a356d220e1d142445 SHA512 08d3f63253fc649adff0fa80615f2956cec042b8ada8511204254112c6da8c175359f692b4c95ee24dde3bb2224c31ddda145ca0a6ea7c9708e351581785b16b WHIRLPOOL f9f3f378cdb50aebf9ededa5a8c0e61bdbbcdef272678a2921aaa3e3ba21f1a79ac00564cdb012b17d62026da6c9692f0b7221929e07e04e6ffad60643280e91
diff --git a/games-util/steam-installer/files/remove-ubuntu-specifics.patch b/games-util/steam-installer/files/remove-ubuntu-specifics.patch
new file mode 100644
index 0000000..b9e5e9e
--- /dev/null
+++ b/games-util/steam-installer/files/remove-ubuntu-specifics.patch
@@ -0,0 +1,39 @@
+--- usr/bin/steam.orig 2012-11-08 11:49:47.959025506 +0100
++++ usr/bin/steam 2012-11-08 11:49:59.588025546 +0100
+@@ -1,26 +1,5 @@
+ #! /bin/bash
+
+-function install_extra_packages() {
+- EXTRA_PACKAGES="$*"
+-
+- # Get the list of packages which are already installed
+- INSTALLED="$(dpkg --get-selections $EXTRA_PACKAGES 2>/dev/null | grep "\binstall$" | cut -f1 | sort)"
+-
+- # compute the list of packages that need to be installed
+- NEEDSINSTALL="$(comm -23 <(echo "$EXTRA_PACKAGES" | tr ' ' '\n' | sort) <(echo "$INSTALLED") | xargs ) "
+-
+- MESSAGE='Enter your password to complete the Steam installation.
+-
+-Steam needs to install these additional packages:
+-'$NEEDSINSTALL
+-
+- if [ $NEEDSINSTALL ]; then
+- # Call gksudo to actually do the work
+- gksudo --disable-grab --message "$MESSAGE" apt-get install $NEEDSINSTALL
+- fi
+-}
+-
+-
+ # these variables can be overridden on commandline
+ LAUNCHSTEAMDIR=~/Steam
+ LAUNCHSTEAMPLATFORM=ubuntu12_32
+@@ -54,9 +33,6 @@
+
+ cp /usr/share/applications/steam.desktop "${DESKTOP_DIR}"
+ chmod +x "${DESKTOP_DIR}/steam.desktop"
+-
+- # Try and install any extra packages
+- install_extra_packages jockey-common python-apt
+ fi
+ # go to the install directory and run the client
+ LAUNCHSTEAMDIR=`readlink -e $STEAMROOTLINK`
diff --git a/games-util/steam-installer/steam-installer-9999.ebuild b/games-util/steam-installer/steam-installer-9999.ebuild
new file mode 100644
index 0000000..33aae3e
--- /dev/null
+++ b/games-util/steam-installer/steam-installer-9999.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils unpacker
+
+DESCRIPTION="Installer for Valve's Steam client for Linux"
+HOMEPAGE="https://steampowered.com"
+SRC_URI="http://media.steampowered.com/client/installer/steam.deb"
+LICENSE="steam"
+RESTRICT='mirror bindist'
+
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=" virtual/opengl
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-20121028
+ >=app-emulation/emul-linux-x86-gtklibs-20121028
+ >=app-emulation/emul-linux-x86-opengl-20121028
+ >=app-emulation/emul-linux-x86-sdl-20121028
+ >=app-emulation/emul-linux-x86-soundlibs-20121028
+ >=app-emulation/emul-linux-x86-xlibs-20121028
+ >=sys-devel/gcc-4.6.0[multilib]
+ >=sys-libs/glibc-2.15[multilib]
+ )
+ x86? (
+ dev-libs/glib:2
+ dev-libs/libgcrypt
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/libjpeg-turbo
+ media-libs/libogg
+ media-libs/libpng:1.2
+ media-libs/libsdl
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ media-sound/pulseaudio
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ >=sys-devel/gcc-4.6.0
+ >=sys-libs/glibc-2.15
+ >=sys-libs/zlib-1.2.4
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ >=x11-libs/libX11-1.5
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/pango
+ >=x11-libs/pixman-0.24.4
+ )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ # fix QA notice
+ sed -r -i "s/^(MimeType=.*)/\1;/" usr/share/applications/steam.desktop
+ sed -r -i "s/^(Actions=.*)/\1;/" usr/share/applications/steam.desktop
+
+ epatch "${FILESDIR}/remove-ubuntu-specifics.patch"
+}
+
+src_install() {
+ dobin "usr/bin/steam"
+
+ insinto "/usr/lib/"
+ doins -r usr/lib/steam
+
+ dodoc usr/share/doc/steam/changelog.gz
+ doman usr/share/man/man6/steam.6.gz
+
+ insinto /usr/share/applications/
+ doins usr/share/applications/steam.desktop
+
+ insinto /usr/share/icons/
+ doins -r usr/share/icons/
+
+ doicon usr/share/pixmaps/steam.xpm
+}
+
+pkg_postinst() {
+ einfo "This ebuild only installs the steam installer."
+ einfo "Execute \"steam\" to install the actual client into"
+ einfo "your home folder."
+
+ ewarn "The steam client and the games are not controlled by"
+ ewarn "portage. Updates are handled by the client itself."
+}
+