summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch')
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch b/app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch
new file mode 100644
index 0000000..f1039d8
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch
@@ -0,0 +1,12 @@
+Index: xen-3.3.0/tools/misc/Makefile
+===================================================================
+--- xen-3.3.0.orig/tools/misc/Makefile
++++ xen-3.3.0/tools/misc/Makefile
+@@ -51,3 +51,7 @@ clean:
+
+ xenperf: %: %.o Makefile
+ $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LDFLAGS_libxenctrl)
++
++xen-detect: %: %.c Makefile
++ $(CC) $(CFLAGS) $(LDFLAGS) $(call cc-option,$(CC),-nopie,) -o $@ $<
++