summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/open-xchange/files/open-xchange-0.8.2_rc3-mysql.patch')
-rw-r--r--www-apps/open-xchange/files/open-xchange-0.8.2_rc3-mysql.patch521
1 files changed, 0 insertions, 521 deletions
diff --git a/www-apps/open-xchange/files/open-xchange-0.8.2_rc3-mysql.patch b/www-apps/open-xchange/files/open-xchange-0.8.2_rc3-mysql.patch
deleted file mode 100644
index bbbbeeb..0000000
--- a/www-apps/open-xchange/files/open-xchange-0.8.2_rc3-mysql.patch
+++ /dev/null
@@ -1,521 +0,0 @@
-diff -rNBwU 2 open-xchange-0.8.2-RC3-origin/conf/admintools.conf.in open-xchange-0.8.2-RC3/conf/admintools.conf.in
---- open-xchange-0.8.2-RC3-origin/conf/admintools.conf.in 2006-02-14 14:33:43.000000000 +0100
-+++ open-xchange-0.8.2-RC3/conf/admintools.conf.in 2006-02-15 14:42:12.000000000 +0100
-@@ -69,5 +69,5 @@
- DEFAULT_SQL_PASS="@dbpass@"
- ### if u want to use mysql change to mysql
--SQL_DB_TYPE="pgsql"
-+SQL_DB_TYPE="mysql"
-
-
-diff -rNBwU 2 open-xchange-0.8.2-RC3-origin/conf/groupware/intranet.conf open-xchange-0.8.2-RC3/conf/groupware/intranet.conf
---- open-xchange-0.8.2-RC3-origin/conf/groupware/intranet.conf 2006-02-14 14:33:43.000000000 +0100
-+++ open-xchange-0.8.2-RC3/conf/groupware/intranet.conf 2006-02-15 15:29:07.000000000 +0100
-@@ -130,16 +130,24 @@
-
- # DATABASE identifiert for SYSDATE
--SYSDATE='now'
-+SYSDATE=now()
-
- # DATABASE identifier for CURRENT_DATE
--# SQL_TODAY='today'
-+SQL_TODAY=curdate()
-
- # Sequence SQL-String for DATABASE
- # Example for POSTGRES
--seq-fid=SELECT nextval ('fid')
--seq-import_id=SELECT nextval ('import_id')
--seq-insert_id=SELECT nextval ('insert_id')
--seq-profile_id=SELECT nextval ('profile_id')
--seq-serial_id=SELECT nextval ('serial_id')
-+#seq-fid=SELECT nextval ('fid')
-+#seq-import_id=SELECT nextval ('import_id')
-+#seq-insert_id=SELECT nextval ('insert_id')
-+#seq-profile_id=SELECT nextval ('profile_id')
-+#seq-serial_id=SELECT nextval ('serial_id')
-+
-+# Example for mySQL
-+seq-fid=SELECT select_fid()
-+seq-import_id=SELECT select_import_id()
-+seq-insert_id=SELECT select_insert_id()
-+seq-profile_id=SELECT select_profile_id()
-+seq-serial_id=SELECT select_serial_id()
-+
- # Example for ORACLE
- #seq-fid="SELECT fid.nextval"
-diff -rNBwU 2 open-xchange-0.8.2-RC3-origin/configure.in open-xchange-0.8.2-RC3/configure.in
---- open-xchange-0.8.2-RC3-origin/configure.in 2006-02-14 14:33:43.000000000 +0100
-+++ open-xchange-0.8.2-RC3/configure.in 2006-02-15 14:59:10.000000000 +0100
-@@ -792,4 +792,5 @@
- conf/admintools.conf
- system/setup/init_ldap.ldif
-+system/setup/create_mysql_database.sql
- src/com/openexchange/server/Version.java )
-
-diff -rNBwU 2 open-xchange-0.8.2-RC3-origin/sbin/deluser_ox.in open-xchange-0.8.2-RC3/sbin/deluser_ox.in
---- open-xchange-0.8.2-RC3-origin/sbin/deluser_ox.in 2006-02-14 14:33:43.000000000 +0100
-+++ open-xchange-0.8.2-RC3/sbin/deluser_ox.in 2006-02-15 15:45:07.000000000 +0100
-@@ -115,9 +115,9 @@
- then
-
-- SQL_INSERT=`$MYSQL_BIN -h $DEFAULT_SQL_HOST -u $DEFAULT_SQL_USER --password=$DEFAULT_SQL_PASS $DEFAULT_SQL_DB -e "DELETE FROM $RIGHTS_TABLE WHERE login LIKE '$USERNAME'" `
-+ SQL_INSERT=`$SQL_BIN -h $DEFAULT_SQL_HOST -U $DEFAULT_SQL_USER -d $DEFAULT_SQL_DB -X -c "DELETE FROM $RIGHTS_TABLE WHERE login LIKE '$USERNAME'" | $AWK_BIN {'print $1'}`
-
- else
-
-- SQL_INSERT=`$SQL_BIN -h $DEFAULT_SQL_HOST -U $DEFAULT_SQL_USER -d $DEFAULT_SQL_DB -X -c "DELETE FROM $RIGHTS_TABLE WHERE login LIKE '$USERNAME'" | $AWK_BIN {'print $1'}`
-+ SQL_INSERT=`$MYSQL_BIN -h $DEFAULT_SQL_HOST -u $DEFAULT_SQL_USER --password=$DEFAULT_SQL_PASS $DEFAULT_SQL_DB -e "DELETE FROM $RIGHTS_TABLE WHERE login LIKE '$USERNAME'" `
- if [ $? -eq 0 ]; then
- SQL_INSERT="DELETE"
-diff -rNBwU 2 open-xchange-0.8.2-RC3-origin/src/com/openexchange/tools/HTMLConfirmation.java open-xchange-0.8.2-RC3/src/com/openexchange/tools/HTMLConfirmation.java
---- open-xchange-0.8.2-RC3-origin/src/com/openexchange/tools/HTMLConfirmation.java 2006-02-14 14:33:43.000000000 +0100
-+++ open-xchange-0.8.2-RC3/src/com/openexchange/tools/HTMLConfirmation.java 2006-02-16 16:08:58.000000000 +0100
-@@ -190,5 +190,5 @@
-
- writeCon = DBPool.pickupWriteable();
-- stmt = writeCon.prepareStatement("UPDATE \"" + table + "\" SET confirm=?, reason=? WHERE (object_id=? AND member_uid LIKE ?)");
-+ stmt = writeCon.prepareStatement("UPDATE " + table + " SET confirm=?, reason=? WHERE (object_id=? AND member_uid LIKE ?)");
- stmt.setString(1, no.user.get("HTMLConfirmReason").toString());
- stmt.setString(2, comment);
-@@ -209,5 +209,5 @@
- try {
- String orig_table = table.startsWith("prg_date") ? "prg_dates" : "prg_tasks";
-- stmt = writeCon.prepareStatement("UPDATE \"" + orig_table + "\" SET changed_from = '" + no.getUser() + "', changing_date = 'NOW' WHERE (intfield01=?)");
-+ stmt = writeCon.prepareStatement("UPDATE " + orig_table + " SET changed_from = '" + no.getUser() + "', changing_date = 'NOW' WHERE (intfield01=?)");
- try {
- stmt.setLong(1, Long.parseLong(objectID));
-diff -rNBwU 2 open-xchange-0.8.2-RC3-origin/system/setup/create_mysql_database.sql.in open-xchange-0.8.2-RC3/system/setup/create_mysql_database.sql.in
---- open-xchange-0.8.2-RC3-origin/system/setup/create_mysql_database.sql.in 1970-01-01 01:00:00.000000000 +0100
-+++ open-xchange-0.8.2-RC3/system/setup/create_mysql_database.sql.in 2006-02-15 14:58:28.000000000 +0100
-@@ -0,0 +1,117 @@
-+DROP DATABASE IF EXISTS @dbname@;
-+
-+CREATE DATABASE @dbname@ DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
-+
-+GRANT ALL PRIVILEGES ON @dbname@.* TO '@dbuser@'@'localhost' IDENTIFIED BY '@dbpass@' WITH GRANT OPTION;
-+GRANT ALL PRIVILEGES ON @dbname@.* TO '@dbuser@'@'%' IDENTIFIED BY '@dbpass@';
-+
-+USE @dbname@;
-+
-+DROP TABLE IF EXISTS table_fid;
-+
-+CREATE TABLE table_fid (
-+ id INT NOT NULL AUTO_INCREMENT,
-+ primary key (id)
-+);
-+
-+DROP FUNCTION IF EXISTS select_fid;
-+
-+DELIMITER //
-+
-+CREATE FUNCTION select_fid () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
-+BEGIN
-+ DECLARE xid INT;
-+ INSERT into table_fid VALUES();
-+ SELECT last_insert_id() into xid;
-+ RETURN xid;
-+END //
-+
-+DELIMITER ;
-+
-+DROP TABLE IF EXISTS table_serial_id;
-+
-+CREATE TABLE table_serial_id (
-+ id INT NOT NULL AUTO_INCREMENT,
-+ primary key (id)
-+) AUTO_INCREMENT = 9;
-+
-+DROP FUNCTION IF EXISTS select_serial_id;
-+
-+DELIMITER //
-+
-+CREATE FUNCTION select_serial_id () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
-+BEGIN
-+ DECLARE xid INT;
-+ INSERT into table_serial_id VALUES();
-+ SELECT last_insert_id() into xid;
-+ RETURN xid;
-+END //
-+
-+DELIMITER ;
-+
-+
-+DROP TABLE IF EXISTS table_import_id;
-+
-+CREATE TABLE table_import_id (
-+ id INT NOT NULL AUTO_INCREMENT,
-+ primary key (id)
-+);
-+
-+DROP FUNCTION IF EXISTS select_import_id;
-+
-+DELIMITER //
-+
-+CREATE FUNCTION select_import_id () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
-+BEGIN
-+ DECLARE xid INT;
-+ INSERT into table_import_id VALUES();
-+ SELECT last_insert_id() into xid;
-+ RETURN xid;
-+END //
-+
-+DELIMITER ;
-+
-+
-+DROP TABLE IF EXISTS table_insert_id;
-+
-+CREATE TABLE table_insert_id (
-+ id INT NOT NULL AUTO_INCREMENT,
-+ primary key (id)
-+) AUTO_INCREMENT = 101;
-+
-+DROP FUNCTION IF EXISTS select_insert_id;
-+
-+DELIMITER //
-+
-+CREATE FUNCTION select_insert_id () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
-+BEGIN
-+ DECLARE xid INT;
-+ INSERT into table_insert_id VALUES();
-+ SELECT last_insert_id() into xid;
-+ RETURN xid;
-+END //
-+
-+DELIMITER ;
-+
-+DROP TABLE IF EXISTS table_profile_id;
-+
-+CREATE TABLE table_profile_id (
-+ id INT NOT NULL AUTO_INCREMENT,
-+ primary key (id)
-+);
-+
-+DROP FUNCTION IF EXISTS select_profile_id;
-+
-+DELIMITER //
-+
-+CREATE FUNCTION select_profile_id () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
-+BEGIN
-+ DECLARE xid INT;
-+ INSERT into table_profile_id VALUES();
-+ SELECT last_insert_id() into xid;
-+ RETURN xid;
-+END //
-+
-+
-+DELIMITER ;
-+
-diff -rNBwU 2 open-xchange-0.8.2-RC3-origin/system/setup/init_mysql_database.sql open-xchange-0.8.2-RC3/system/setup/init_mysql_database.sql
---- open-xchange-0.8.2-RC3-origin/system/setup/init_mysql_database.sql 2006-02-14 14:33:43.000000000 +0100
-+++ open-xchange-0.8.2-RC3/system/setup/init_mysql_database.sql 2006-02-15 15:22:55.000000000 +0100
-@@ -1,111 +1,2 @@
--
--DROP TABLE IF EXISTS table_fid;
--
--CREATE TABLE table_fid (
-- id INT NOT NULL AUTO_INCREMENT,
-- primary key (id)
--);
--
--DROP FUNCTION IF EXISTS select_fid;
--
--DELIMITER //
--
--CREATE FUNCTION select_fid () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
--BEGIN
-- DECLARE xid INT;
-- INSERT into table_fid VALUES();
-- SELECT last_insert_id() into xid;
-- RETURN xid;
--END //
--
--DELIMITER ;
--
--DROP TABLE IF EXISTS table_serial_id;
--
--CREATE TABLE table_serial_id (
-- id INT NOT NULL AUTO_INCREMENT,
-- primary key (id)
--) AUTO_INCREMENT = 9;
--
--DROP FUNCTION IF EXISTS select_serial_id;
--
--DELIMITER //
--
--CREATE FUNCTION select_serial_id () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
--BEGIN
-- DECLARE xid INT;
-- INSERT into table_serial_id VALUES();
-- SELECT last_insert_id() into xid;
-- RETURN xid;
--END //
--
--DELIMITER ;
--
--
--DROP TABLE IF EXISTS table_import_id;
--
--CREATE TABLE table_import_id (
-- id INT NOT NULL AUTO_INCREMENT,
-- primary key (id)
--);
--
--DROP FUNCTION IF EXISTS select_import_id;
--
--DELIMITER //
--
--CREATE FUNCTION select_import_id () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
--BEGIN
-- DECLARE xid INT;
-- INSERT into table_import_id VALUES();
-- SELECT last_insert_id() into xid;
-- RETURN xid;
--END //
--
--DELIMITER ;
--
--
--DROP TABLE IF EXISTS table_insert_id;
--
--CREATE TABLE table_insert_id (
-- id INT NOT NULL AUTO_INCREMENT,
-- primary key (id)
--) AUTO_INCREMENT = 101;
--
--DROP FUNCTION IF EXISTS select_insert_id;
--
--DELIMITER //
--
--CREATE FUNCTION select_insert_id () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
--BEGIN
-- DECLARE xid INT;
-- INSERT into table_insert_id VALUES();
-- SELECT last_insert_id() into xid;
-- RETURN xid;
--END //
--
--DELIMITER ;
--
--DROP TABLE IF EXISTS table_profile_id;
--
--CREATE TABLE table_profile_id (
-- id INT NOT NULL AUTO_INCREMENT,
-- primary key (id)
--);
--
--DROP FUNCTION IF EXISTS select_profile_id;
--
--DELIMITER //
--
--CREATE FUNCTION select_profile_id () RETURNS INTEGER DETERMINISTIC MODIFIES SQL DATA
--BEGIN
-- DECLARE xid INT;
-- INSERT into table_profile_id VALUES();
-- SELECT last_insert_id() into xid;
-- RETURN xid;
--END //
--
--
--DELIMITER ;
--
- CREATE TABLE prg_dlist (
- intfield01 integer,
-@@ -446,5 +337,5 @@
- timestampfield01 timestamp ,
- timestampfield02 timestamp ,
-- intfield01 int NOT NULL,
-+ intfield01 int PRIMARY KEY,
- intfield02 int,
- intfield03 int,
-@@ -1127,5 +1018,5 @@
- CREATE TABLE projects_notes (
- intfield01 integer,
-- note_id VARCHAR (255),
-+ note_id VARCHAR(166),
- member_id text,
- primary key (intfield01, note_id),
-@@ -1135,5 +1026,5 @@
- CREATE TABLE backup_projects_notes (
- intfield01 integer,
-- note_id VARCHAR (255),
-+ note_id VARCHAR(166),
- member_id text,
- primary key (intfield01, note_id),
-@@ -1178,5 +1069,5 @@
- intfield01 integer,
- id integer,
-- antecessor VARCHAR (255),
-+ antecessor VARCHAR(166),
- object_type integer,
- primary key (intfield01, id, antecessor),
-@@ -1187,5 +1078,5 @@
- intfield01 integer,
- id integer,
-- antecessor VARCHAR (255),
-+ antecessor VARCHAR(166),
- object_type integer,
- primary key (intfield01, id, antecessor),
-@@ -1328,5 +1219,35 @@
- timestampfield01 timestamp ,
- timestampfield02 timestamp ,
-- intfield01 int NOT NULL,
-+ intfield01 int PRIMARY KEY,
-+ intfield02 int,
-+ intfield03 int,
-+ intfield04 int,
-+ intfield05 int,
-+ intfield06 int,
-+ field01 text NOT NULL,
-+ field02 text,
-+ field03 text,
-+ field04 text,
-+ field05 text,
-+ field06 text,
-+ field07 text,
-+ field08 text,
-+ field09 text,
-+ field10 text
-+);
-+
-+CREATE TABLE del_docufolders (
-+ creating_date timestamp NOT NULL,
-+ created_from text NOT NULL,
-+ changing_date timestamp,
-+ changed_from text,
-+ user_right text NOT NULL,
-+ group_right text NOT NULL,
-+ sid text NOT NULL,
-+ tid text,
-+ order_crit text,
-+ timestampfield01 timestamp,
-+ timestampfield02 timestamp,
-+ intfield01 int PRIMARY KEY,
- intfield02 int,
- intfield03 int,
-@@ -1358,5 +1279,35 @@
- timestampfield01 timestamp ,
- timestampfield02 timestamp ,
-- intfield01 int NOT NULL,
-+ intfield01 int PRIMARY KEY,
-+ intfield02 int NOT NULL,
-+ intfield03 int,
-+ intfield04 int,
-+ intfield05 int,
-+ intfield06 int,
-+ field01 text NOT NULL,
-+ field02 text,
-+ field03 text,
-+ field04 text,
-+ field05 text,
-+ field06 text,
-+ field07 text,
-+ field08 text,
-+ field09 text,
-+ field10 text
-+);
-+
-+CREATE TABLE del_documents (
-+ creating_date timestamp NOT NULL,
-+ created_from text NOT NULL,
-+ changing_date timestamp,
-+ changed_from text,
-+ user_right text NOT NULL,
-+ group_right text NOT NULL,
-+ sid text NOT NULL,
-+ tid text,
-+ order_crit text,
-+ timestampfield01 timestamp,
-+ timestampfield02 timestamp,
-+ intfield01 int PRIMARY KEY,
- intfield02 int NOT NULL,
- intfield03 int,
-@@ -1388,5 +1339,35 @@
- timestampfield01 timestamp ,
- timestampfield02 timestamp ,
-- intfield01 int NOT NULL,
-+ intfield01 int PRIMARY KEY,
-+ intfield02 int NOT NULL,
-+ intfield03 int NOT NULL,
-+ intfield04 int,
-+ intfield05 int,
-+ intfield06 int,
-+ field01 text NOT NULL,
-+ field02 text,
-+ field03 text NOT NULL,
-+ field04 text NOT NULL,
-+ field05 text,
-+ field06 text,
-+ field07 text,
-+ field08 text,
-+ field09 text,
-+ field10 text
-+);
-+
-+CREATE TABLE del_documents_files (
-+ creating_date timestamp NOT NULL,
-+ created_from text,
-+ changing_date timestamp,
-+ changed_from text,
-+ user_right text,
-+ group_right text,
-+ sid text NOT NULL,
-+ tid text,
-+ order_crit text,
-+ timestampfield01 timestamp,
-+ timestampfield02 timestamp,
-+ intfield01 int PRIMARY KEY,
- intfield02 int NOT NULL,
- intfield03 int NOT NULL,
-@@ -1971,5 +1952,5 @@
- CREATE TABLE sys_linkage (
- changing_date timestamp NOT NULL,
-- luid int NOT NULL,
-+ luid int PRIMARY KEY,
- source_id int NOT NULL,
- src_table text NOT NULL,
-@@ -1991,5 +1972,5 @@
- CREATE TABLE del_linkage (
- changing_date timestamp NOT NULL,
-- luid int NOT NULL,
-+ luid int PRIMARY KEY,
- source_id int NOT NULL,
- src_table text NOT NULL,
-@@ -2045,4 +2026,10 @@
- );
-
-+CREATE TABLE oxfolder_userfolders_standardfolders (
-+ owner text,
-+ module text,
-+ fuid int
-+);
-+
- CREATE TABLE del_oxfolder_tree (
- fuid int,
-@@ -2109,12 +2096,18 @@
- );
-
--INSERT INTO oxfolder_tree VALUES (1, 0, 'private', 'system', 'system','system', 'system', now(), 'System', null, null);
--INSERT INTO oxfolder_tree VALUES (2, 0, 'public', 'system', 'system','system', 'system', now(), 'System', null, null);
--INSERT INTO oxfolder_tree VALUES (3, 0, 'shared', 'system', 'system','system', 'system', now(), 'System', null, null);
--INSERT INTO oxfolder_tree VALUES (4, 0, 'system', 'system', 'system','system', 'system', now(), 'System', null, null);
--INSERT INTO oxfolder_tree VALUES (5, 4, 'system_global', 'contact', 'system','system', 'system', now(), 'System', null, null);
--INSERT INTO oxfolder_tree VALUES (6, 4, 'system_ldap', 'contact', 'system','system', 'system', now(), 'System', null, null);
--INSERT INTO oxfolder_tree VALUES (7, 0, 'user', 'system', 'system','system', 'system', now(), 'System', null, null);
--INSERT INTO oxfolder_tree VALUES (8, 7, 'projects', 'projects', 'system','system', 'system', now(), 'System', null, null);
-+CREATE TABLE del_system_objects (
-+ object_type int,
-+ object_id text,
-+ deleting_date timestamp
-+);
-+
-+INSERT INTO oxfolder_tree VALUES (1, 0, 'private', 'system', 'system','system', 'system', 'now', 'System', null, null);
-+INSERT INTO oxfolder_tree VALUES (2, 0, 'public', 'system', 'system','system', 'system', 'now', 'System', null, null);
-+INSERT INTO oxfolder_tree VALUES (3, 0, 'shared', 'system', 'system','system', 'system', 'now', 'System', null, null);
-+INSERT INTO oxfolder_tree VALUES (4, 0, 'system', 'system', 'system','system', 'system', 'now', 'System', null, null);
-+INSERT INTO oxfolder_tree VALUES (5, 4, 'system_global', 'contact', 'system','system', 'system', 'now', 'System', null, null);
-+INSERT INTO oxfolder_tree VALUES (6, 4, 'system_ldap', 'contact', 'system','system', 'system', 'now', 'System', null, null);
-+INSERT INTO oxfolder_tree VALUES (7, 0, 'user', 'system', 'system','system', 'system', 'now', 'System', null, null);
-+INSERT INTO oxfolder_tree VALUES (8, 7, 'projects', 'projects', 'system','system', 'system', 'now', 'System', null, null);
-
- INSERT INTO oxfolder_permissions VALUES (select_serial_id(), 1, 512,'all_ox_users_and_ox_groups', 0, 8, 0, 0, 0);
-