summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2010-09-19 20:02:34 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2010-09-19 20:02:34 +0900
commit18acba2a90c5d276ce621e5f6977267a92c951a9 (patch)
tree9b13984ec1e5152ed8cd15210d35a2cb3ab8c4a0 /app-text/groonga/groonga-1.0.2.ebuild
parentdev-ruby/rubytter: Version bumped. (diff)
downloadmatsuu-18acba2a90c5d276ce621e5f6977267a92c951a9.tar.gz
matsuu-18acba2a90c5d276ce621e5f6977267a92c951a9.tar.bz2
matsuu-18acba2a90c5d276ce621e5f6977267a92c951a9.zip
app-text/groonga: Initial import
Diffstat (limited to 'app-text/groonga/groonga-1.0.2.ebuild')
-rw-r--r--app-text/groonga/groonga-1.0.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/groonga/groonga-1.0.2.ebuild b/app-text/groonga/groonga-1.0.2.ebuild
new file mode 100644
index 0000000..a2ef3de
--- /dev/null
+++ b/app-text/groonga/groonga-1.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://groonga.org/files/groonga/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="abort aio cutter fmalloc futex libedit lzo mecab +nfkc ruby sphinx uyield zlib"
+IUSE="libedit lzo mecab ruby sphinx zlib"
+
+RDEPEND="libedit? ( dev-libs/libedit )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ ruby? ( dev-lang/ruby )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+# cutter? ( >=cutter-1.1.3 )
+#>=glib-2.8
+#ruby
+#lzo
+# libedit? ( >=dev-libs/libedit-3.0 )
+
+src_configure() {
+ econf \
+ $(use_with ruby) \
+ $(use_with libedit) \
+ $(use_with lzo) \
+ $(use_with sphinx sphinx-build) \
+ $(use_with mecab) \
+ $(use_with zlib) || die
+# $(use_with cutter) \
+# $(use_enable libedit) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ keepdir /var/log/${PN} || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}