summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0006-Clean-up-some-left-over-libtool-lint.patch')
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0006-Clean-up-some-left-over-libtool-lint.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0006-Clean-up-some-left-over-libtool-lint.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0006-Clean-up-some-left-over-libtool-lint.patch
new file mode 100644
index 0000000..db38aaf
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.16.08/0006-Clean-up-some-left-over-libtool-lint.patch
@@ -0,0 +1,67 @@
+From 2bcb3261e2e6f4345a5ab62d563fa3a484b04182 Mon Sep 17 00:00:00 2001
+From: Peter Alfredsen <loki_val@gentoo.org>
+Date: Thu, 22 Jan 2009 14:57:46 +0100
+Subject: [PATCH 06/10] Clean up some left-over libtool lint
+
+---
+ configure.in | 5 -----
+ tools/xmlrpc_transport/Makefile | 7 -------
+ 2 files changed, 0 insertions(+), 12 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 60e3cf8..e1e19d2 100644
+--- a/configure.in
++++ b/configure.in
+@@ -117,8 +117,6 @@ fi
+
+ dnl Set up the appropriate Makefile substitutions.
+
+-LIBXMLRPC_CLIENT_LA=libxmlrpc_client.la
+-AC_SUBST(LIBXMLRPC_CLIENT_LA)
+ CLIENTTEST=clienttest
+ AC_SUBST(CLIENTTEST)
+ XMLRPC_CLIENT_H=xmlrpc_client.h
+@@ -155,7 +153,6 @@ AC_SUBST(ENABLE_ABYSS_SERVER)
+
+ dnl Set up the appropriate Makefile substitutions.
+ ABYSS_SUBDIR=
+-LIBXMLRPC_ABYSS_SERVER_LA=
+ SERVERTEST=
+ VALIDATEE=
+ XMLRPC_ABYSS_H=
+@@ -163,14 +160,12 @@ SERVER=
+ if test x"$enable_abyss_server" != xno; then
+ FEATURE_LIST="abyss-server $FEATURE_LIST"
+ ABYSS_SUBDIR=abyss
+- LIBXMLRPC_ABYSS_SERVER_LA=libxmlrpc_abyss_server.la
+ SERVERTEST=servertest
+ VALIDATEE=validatee
+ XMLRPC_ABYSS_H=xmlrpc_abyss.h
+ SERVER=server
+ fi
+ AC_SUBST(ABYSS_SUBDIR)
+-AC_SUBST(LIBXMLRPC_ABYSS_SERVER_LA)
+ AC_SUBST(SERVERTEST)
+ AC_SUBST(VALIDATEE)
+ AC_SUBST(XMLRPC_ABYSS_H)
+diff --git a/tools/xmlrpc_transport/Makefile b/tools/xmlrpc_transport/Makefile
+index 29cf55c..915d745 100644
+--- a/tools/xmlrpc_transport/Makefile
++++ b/tools/xmlrpc_transport/Makefile
+@@ -39,13 +39,6 @@ UTIL_OBJS = \
+
+ UTILS = $(UTIL_OBJS:%=$(UTIL_DIR)/%)
+
+-# These are the Libtool .la files. We use them only for make dependencies.
+-# We'd like to use these in the link rule, by using libtool --link, but
+-# Libtool adds -l options to the link to cover the dependencies that are
+-# recorded inside the shared libraries. And it doesn't add the necessary
+-# -L options (it can't), so we end up with a messy mixture of the two
+-# forms of specifying libraries.
+-
+ LIBS = $(LIBXMLRPC_CLIENT) $(LIBXMLRPC) $(LIBXMLRPC_XML) $(LIBXMLRPC_UTIL)
+
+ xmlrpc_transport:%:%.o $(LIBS) $(UTILS)
+--
+1.6.1
+