summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-07-28 14:02:57 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-07-28 14:02:57 +0000
commit1529633744ce3d0b157746e34031600611982f2c (patch)
tree6e66e723f7497235d96303a67621f3a1e3fe97d7 /x11-libs
parentadd RESTRICT="mirror" and check_license to comply with PUEL wrt bug #279198 (diff)
downloadjokey-1529633744ce3d0b157746e34031600611982f2c.tar.gz
jokey-1529633744ce3d0b157746e34031600611982f2c.tar.bz2
jokey-1529633744ce3d0b157746e34031600611982f2c.zip
Initial all for wxwebconnect
svn path=/trunk/; revision=705
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxwebconnect/Manifest3
-rw-r--r--x11-libs/wxwebconnect/files/wxwebconnect-1.0-debundle.patch27
-rw-r--r--x11-libs/wxwebconnect/wxwebconnect-1.0.ebuild37
3 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/wxwebconnect/Manifest b/x11-libs/wxwebconnect/Manifest
new file mode 100644
index 0000000..5060431
--- /dev/null
+++ b/x11-libs/wxwebconnect/Manifest
@@ -0,0 +1,3 @@
+AUX wxwebconnect-1.0-debundle.patch 664 RMD160 0d5f86f8665e3aef917f45c47c68c2b9f261c5d9 SHA1 2e14cc6e5d008b4afc1d931eda8cf3d62876c6b7 SHA256 f8fe7342c8d3f5caf66155e34f90b03b54b480983edab17847add09641d798c7
+DIST webconnect-1.0.tar.gz 7235594 RMD160 53ca2e9bb7ec347e4a5ce0580aace95df2047add SHA1 634c68a5bf6eac5a2769422e89754c7fa06c0b02 SHA256 243b8d0eba18aea6401430895c72050084839f7ed3c34f5d1903bed1e1ac12ba
+EBUILD wxwebconnect-1.0.ebuild 709 RMD160 0af8a658455fbd2a9f215f67332b15e0be4cb800 SHA1 711f4daa4ab6c00dee89783a2bd7d07038a2a58e SHA256 6a324c5f432650718f8d441419bd17b600d93534c450e0ace2bcf52a502c5acf
diff --git a/x11-libs/wxwebconnect/files/wxwebconnect-1.0-debundle.patch b/x11-libs/wxwebconnect/files/wxwebconnect-1.0-debundle.patch
new file mode 100644
index 0000000..1d98f2b
--- /dev/null
+++ b/x11-libs/wxwebconnect/files/wxwebconnect-1.0-debundle.patch
@@ -0,0 +1,27 @@
+diff -urN ./webconnect.orig/Makefile ./webconnect/Makefile
+--- ./webconnect.orig/Makefile 2009-07-06 16:24:00.000000000 +0200
++++ ./webconnect/Makefile 2009-07-28 15:56:37.689710873 +0200
+@@ -12,14 +12,8 @@
+ #
+ # ---------------------------------------------------------------------------
+
+-include ../top.mak
+-
+-
+ INCLUDES =
+-DEFINES = ${LARGEFILE_DEFINES}
+-CFLAGS = ${WX_CFLAGS} -g -ggdb -fno-rtti
+-LIBS = ${WX_LIBS}
+-
++CFLAGS = $(shell wx-config --cppflags) -g -ggdb -fno-rtti
+
+ OBJECTS = \
+ dom.o \
+@@ -40,6 +34,6 @@
+
+ $(OBJECTS): %.o : %.cpp
+ @echo $<
+- $(CPP) $(CFLAGS) $(INCLUDES) $(DEFINES) -c $<
++ $(CXX) $(CFLAGS) $(INCLUDES) $(DEFINES) -c $<
+
+
diff --git a/x11-libs/wxwebconnect/wxwebconnect-1.0.ebuild b/x11-libs/wxwebconnect/wxwebconnect-1.0.ebuild
new file mode 100644
index 0000000..ca180f3
--- /dev/null
+++ b/x11-libs/wxwebconnect/wxwebconnect-1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="XUL interface for HTML rendering in wx Toolkit"
+HOMEPAGE="http://www.kirix.com/labs/wxwebconnect"
+SRC_URI="http://downloads.kirix.com/labs/wxwebconnect/webconnect-1.0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/webconnect
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-debundle.patch
+}
+
+src_compile() {
+ cd ${S}/webconnect
+ emake -j1|| die "emake failed"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)
+ doins webconnect/libwebconnect.a
+ insinto /usr/include/wx-2.8/wx
+ doins webconnect/*.h
+} \ No newline at end of file