summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorx-drum <x-drum@localhost>2008-06-06 15:50:35 +0000
committerx-drum <x-drum@localhost>2008-06-06 15:50:35 +0000
commit64a69e35936f49f608cd757b57b6a1bfcccc5f47 (patch)
tree14b1acdd979d4d065741a0d3fc1a5a9caa1a0646 /x11-drivers
parentapp-emulation/virtualbox-bin: Version bump (diff)
downloadjokey-64a69e35936f49f608cd757b57b6a1bfcccc5f47.tar.gz
jokey-64a69e35936f49f608cd757b57b6a1bfcccc5f47.tar.bz2
jokey-64a69e35936f49f608cd757b57b6a1bfcccc5f47.zip
x11-drivers/xf86-video-virtualbox: Version bump
svn path=/trunk/; revision=416
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-virtualbox/ChangeLog4
-rw-r--r--x11-drivers/xf86-video-virtualbox/Manifest4
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-1.6.2.ebuild61
3 files changed, 68 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-virtualbox/ChangeLog b/x11-drivers/xf86-video-virtualbox/ChangeLog
index da43807..c1c4733 100644
--- a/x11-drivers/xf86-video-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-video-virtualbox/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Jun 2008; Alessio Cassibba (X-Drum) <swapon@gmail.com>
+ +xf86-video-virtualbox-1.6.2.ebuild:
+ Version bump
+
05 Jun 2008; Alessio Cassibba (X-Drum) <swapon@gmail.com>
+xf86-video-virtualbox-1.6.0.ebuild, +metadata.xml:
Version bump wrt bug #220144
diff --git a/x11-drivers/xf86-video-virtualbox/Manifest b/x11-drivers/xf86-video-virtualbox/Manifest
index 15c1964..7ae21d5 100644
--- a/x11-drivers/xf86-video-virtualbox/Manifest
+++ b/x11-drivers/xf86-video-virtualbox/Manifest
@@ -1,4 +1,6 @@
DIST VirtualBox-1.6.0-OSE.tar.bz2 35404676 RMD160 f31610a06ff1b884d8ac762744f6bd4ec9871268 SHA1 c20e8e2150cc1867e1c2fee7c21211391072aee2 SHA256 c869f06479441e779c4039a7317ac5aeff83061d8e7b32308eac392363560cac
+DIST VirtualBox-1.6.2-OSE.tar.bz2 35409803 RMD160 9a5fe4746b41a46403921c7a400460cc7abc3c81 SHA1 6811a580b70e651f36002f344033e1db1858fdef SHA256 f458e6ad674ae54ea67b2c8b08816c87b1c4768ec9d43ca041d64a2bcec4eb3b
EBUILD xf86-video-virtualbox-1.6.0.ebuild 1379 RMD160 1ac121a4ae7ace65be97333acdd41420b6ae28e4 SHA1 3f1b68c20faa0a95c5082fd8481793f7ec148902 SHA256 0fa483f5c66f3b95cf523360b129871f4f170580f1c6f97faf5d8f15523d18bc
-MISC ChangeLog 280 RMD160 a47367a0cc267177d85e3ecf65e3309a3b7aca50 SHA1 6860e2a0953da0c90153aeb3e85d6bc4e7d5769a SHA256 acc40b2a03fd3fb07bed67f6cfd10bcf85b5e4b99e0e6ab9f619b6506fb48300
+EBUILD xf86-video-virtualbox-1.6.2.ebuild 1375 RMD160 b72aa81f2328d1ba6935915cf8ca4ad6f027eab6 SHA1 ea835e11f4c5385a3afb41d2790ebdcbc562ef61 SHA256 5afb3ae9ef80fdbb4c51243d9f52fe0ce3a448d0571dd06667f48ba05abdae06
+MISC ChangeLog 395 RMD160 0e99ba265235ada2f27795b7866d40bddca9fe1e SHA1 2c66ee2c9c4e56aca035164f4bc5492a9cc5b392 SHA256 9fa419671b6aa9c34940e246cd4cc480a9bcdfd9d54b744eaad6ea446618ca30
MISC metadata.xml 344 RMD160 12935d5b21be85bc4222fd06371c93dcbf6f534e SHA1 68b99919921f246738cce4350b77d895e7c78106 SHA256 fff5aeb6f453d2e137765ca5016e81344cb0cd0cecd51d81bbb889cb1d7a5ba9
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-1.6.2.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-1.6.2.ebuild
new file mode 100644
index 0000000..d95c7a4
--- /dev/null
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-1.6.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit x-modular eutils
+
+MY_P=VirtualBox-${PV}-OSE
+DESCRIPTION="VirtualBox video driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P/-OSE/}
+
+src_compile() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+
+ cd "${S}/src/VBox/Additions/linux/xgraphics"
+
+ MAKE="kmk" emake || die "kmk failed"
+}
+
+src_install() {
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/lib/xorg/modules/drivers
+
+ if has_version "<x11-base/xorg-server-1.4" ; then
+ newins vboxvideo_drv_13.so vboxvideo_drv.so
+ else
+ newins vboxvideo_drv_14.so vboxvideo_drv.so
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxvideo\""
+ elog ""
+ elog "in the Graphics device section (Section \"Device\")"
+ elog ""
+}