summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-09-05 14:16:52 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-09-05 14:16:52 +0000
commitd391ea6d84f5f9a6cc7470f0ddd3a70947cdb6e2 (patch)
tree8d6edf6a4b45db47972c010df6ed2075aded1989
parentVersion bump; prune old ebuilds in overlay (diff)
downloadjokey-d391ea6d84f5f9a6cc7470f0ddd3a70947cdb6e2.tar.gz
jokey-d391ea6d84f5f9a6cc7470f0ddd3a70947cdb6e2.tar.bz2
jokey-d391ea6d84f5f9a6cc7470f0ddd3a70947cdb6e2.zip
Add netatalk 2.1 live version so TimeMachine and Spotlight work smoothly
svn path=/trunk/; revision=716
-rw-r--r--net-fs/netatalk/ChangeLog10
-rw-r--r--net-fs/netatalk/Manifest3
-rw-r--r--net-fs/netatalk/metadata.xml9
-rw-r--r--net-fs/netatalk/netatalk-2.1_pre9999.ebuild94
4 files changed, 116 insertions, 0 deletions
diff --git a/net-fs/netatalk/ChangeLog b/net-fs/netatalk/ChangeLog
new file mode 100644
index 0000000..7f6a1b1
--- /dev/null
+++ b/net-fs/netatalk/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-fs/netatalk
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*netatalk-2.1_pre9999 (05 Sep 2009)
+
+ 05 Sep 2009; Markus Ullmann <jokey@gentoo.org>
+ +netatalk-2.1_pre9999.ebuild, +metadata.xml:
+ Add netatalk 2.1 live version so TimeMachine and Spotlight work smoothly
+
diff --git a/net-fs/netatalk/Manifest b/net-fs/netatalk/Manifest
new file mode 100644
index 0000000..7db7752
--- /dev/null
+++ b/net-fs/netatalk/Manifest
@@ -0,0 +1,3 @@
+EBUILD netatalk-2.1_pre9999.ebuild 2836 RMD160 72753e5c09e51d12468b983773add7ca9d795ad8 SHA1 89032c022912702bfa1341ee93b5152d0d132c0c SHA256 4a0cdf072cbc5e723f1ff2e54a33942d8f6014e8c2821a6937b0d0ad393d2a07
+MISC ChangeLog 325 RMD160 949f7e26dc736078738ee1b912ba045e26b35e83 SHA1 c1d8b56af58c63d7c70c0f7962af68c1763e07da SHA256 e6f738322c76c8fc1d545b18629c21b4fc5f1f24b2f0f789fbdb8696185c9a6b
+MISC metadata.xml 321 RMD160 4cf5a812670dc659b0325e35aa5813f24a8e7499 SHA1 bc376e37383b2f1876644258113fc0e954f8b5f0 SHA256 1f2660dd2dd2f8a210ed6df840e16e23bc9a19d5777a3776cbaecad689bcdeee
diff --git a/net-fs/netatalk/metadata.xml b/net-fs/netatalk/metadata.xml
new file mode 100644
index 0000000..50687dc
--- /dev/null
+++ b/net-fs/netatalk/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-fs</herd>
+<longdescription>kernel level implementation of the AppleTalk protocol suite</longdescription>
+<use>
+ <flag name='xfs'>Enable support for XFS Quota</flag>
+</use>
+</pkgmetadata>
diff --git a/net-fs/netatalk/netatalk-2.1_pre9999.ebuild b/net-fs/netatalk/netatalk-2.1_pre9999.ebuild
new file mode 100644
index 0000000..03cab33
--- /dev/null
+++ b/net-fs/netatalk/netatalk-2.1_pre9999.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.0.3-r4.ebuild,v 1.5 2009/05/21 20:24:33 ranger Exp $
+
+EAPI=2
+
+inherit eutils pam autotools cvs
+
+ECVS_SERVER="netatalk.cvs.sourceforge.net:/cvsroot/netatalk"
+ECVS_MODULE="netatalk"
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="Kernel level implementation of the AppleTalk Protocol Suite"
+HOMEPAGE="http://netatalk.sourceforge.net/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="ssl pam tcpd slp cups kerberos krb4 debug cracklib xfs"
+
+RDEPEND=">=sys-libs/db-4.2.52
+ cracklib? ( sys-libs/cracklib )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ slp? ( net-libs/openslp )
+ cups? ( net-print/cups )
+ kerberos? ( virtual/krb5 )
+ krb4? ( virtual/krb5 )
+ >=sys-apps/coreutils-7.1"
+DEPEND="${RDEPEND}
+ xfs? ( sys-fs/xfsprogs <sys-kernel/linux-headers-2.6.16 )"
+
+src_prepare() {
+ # until someone that understands their config script build
+ # system gets a patch pushed upstream to make
+ # --enable-srvloc passed to configure also add slpd to the
+ # use line on the initscript, we'll need to do it this way
+ if use slp; then
+ myconf="${myconf} --enable-srvloc"
+ sed -i -e 's/^\([[:space:]]*use[[:space:][:alnum:]]*\)$/\1 slpd/' \
+ "${S}"/distrib/initscripts/rc.atalk.gentoo.tmpl
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # Ignore --enable-gentoo, we install the init.d by hand and we avoid having to
+ # sed the Makefiles to not do rc-update.
+ econf \
+ $(use_with pam) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable tcpd tcp-wrappers) \
+ $(use_enable kerberos krbV-uam) \
+ $(use_enable krb4 krb4-uam) \
+ $(use_enable slp srvloc) \
+ $(use_with ssl ssl-dir) \
+ $(use_with cracklib) \
+ $(use_with elibc_glibc shadow) \
+ $(use_with xfs) \
+ --disable-afs \
+ --enable-fhs \
+ --with-cnid-cdb-backend \
+ --with-bdb=/usr
+}
+
+src_compile() {
+ emake || die "netatalk emake failed"
+
+ # Create the init script manually (it's more messy to --enable-gentoo)
+ cd "${S}"/distrib/initscripts
+ emake rc.atalk.gentoo
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "netatalk make install failed"
+
+ dodoc CONTRIBUTORS NEWS README TODO VERSION
+
+ newinitd "${S}"/distrib/initscripts/rc.atalk.gentoo atalk
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${D}/etc/pam.d"
+ pamd_mimic_system netatalk auth account password session
+
+ # Move /usr/include/netatalk to /usr/include/netatalk2 to avoid collisions
+ # with /usr/include/netatalk/at.h provided by glibc (strange, uh?)
+ # Packages that wants to link to netatalk should then probably change the
+ # includepath then, but right now, nothing uses netatalk.
+ # On a side note, it also solves collisions with freebsd-lib and other libcs
+ mv "${D}"/usr/include/netatalk{,2}
+}