aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vagrant-bin/vagrant-bin-2.1.2.ebuild')
-rw-r--r--app-emulation/vagrant-bin/vagrant-bin-2.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/vagrant-bin/vagrant-bin-2.1.2.ebuild b/app-emulation/vagrant-bin/vagrant-bin-2.1.2.ebuild
new file mode 100644
index 0000000..3956aca
--- /dev/null
+++ b/app-emulation/vagrant-bin/vagrant-bin-2.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN/-bin/}
+inherit unpacker eutils
+
+DESCRIPTION="Tool for building and distributing virtual machines"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://releases.hashicorp.com/${MY_PN}/${PV}/${MY_PN}_${PV}_x86_64.deb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/opt/${MY_PN}"
+
+RDEPEND="
+ app-arch/libarchive
+ net-misc/curl
+ !app-emulation/vagrant
+"
+
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ local dir="/opt/${MY_PN}"
+ dodir ${dir}
+ cp -ar ./* "${ED%/}${dir}" || die "copy files failed"
+
+ make_wrapper "${MY_PN}" "${dir}/bin/${MY_PN}"
+}