summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2024-05-13 06:52:46 +0200
committerHans de Graaff <hans@degraaff.org>2024-05-13 06:52:46 +0200
commita393334d4146d67b7e574d2744ad8e573a721624 (patch)
tree160508d38deca809cb55408baabededf640bfff5 /dev-ruby/rubocop
parentdev-ruby/money: add 6.19.0 (diff)
downloadgraaff-a393334d4146d67b7e574d2744ad8e573a721624.tar.gz
graaff-a393334d4146d67b7e574d2744ad8e573a721624.tar.bz2
graaff-a393334d4146d67b7e574d2744ad8e573a721624.zip
dev-ruby/rubocop: add 1.63.5
Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-ruby/rubocop')
-rw-r--r--dev-ruby/rubocop/Manifest1
-rw-r--r--dev-ruby/rubocop/rubocop-1.63.5.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/rubocop/Manifest b/dev-ruby/rubocop/Manifest
index fa2a36e6..91832b0d 100644
--- a/dev-ruby/rubocop/Manifest
+++ b/dev-ruby/rubocop/Manifest
@@ -4,3 +4,4 @@ DIST rubocop-1.62.1.tar.gz 2484709 BLAKE2B 8a14e27a2b115b3a1f5f6bd7370216ad6722e
DIST rubocop-1.63.2.tar.gz 2494776 BLAKE2B 2ccf184e84fb0ef41629811123b9f4d5c74a6fad3a41167d6eedcc5d8cec5975fc63eabdfe5d1c21c010ccf7d8233be5b7888bf9f5c9092ecbc81c005d066e04 SHA512 3539133414b026f472d56d65b2ef8a34ed300358950e2257c4d73dc0e3b30dfb25ef2070aee95df9d72be5621977c6f0546dea5703f937a04c846cf7e41299c1
DIST rubocop-1.63.3.tar.gz 2495237 BLAKE2B 345df48c0b5b840e83f6ef4be5c16f99fb9cf8482d76cccf0ff3feb1579de7ba0496b0fe3da9f0f114861cafe28b749268b4bbe603f74cb377ed157069a900d4 SHA512 d042a0885edecb18509eb49473876a4883781d2e1a5716c21e47e4f9097e7744dae22c7e3fba2e1d1413f68160ed9c181a62ea4a442a26b0e83399d5c2ee3f69
DIST rubocop-1.63.4.tar.gz 2495715 BLAKE2B 44d4d7ea511ca1b30c776346fd34a11aacc181ba497d77a0cd5c7747c22bc1916f0e0b8b61c8439065686ece5405a6016c8bb628e99d839629f2829e968e5dfa SHA512 00759184f8770f537a99b68676c46eca7db24ae5e9eb8cc510a7ff55680b9799f89bd278efb412981e62414dcc346b876ec6189cbbee7b9156e50a0ae6bcbe67
+DIST rubocop-1.63.5.tar.gz 2496760 BLAKE2B ddbd0753f6126256e877a53c1bcf42216cf54926f2d2e69f02de67f1c6eec70913502feafed4d6d4669f145b155816d8f0b028f97ee468e688ca472d689c2b2f SHA512 8ae0d104f634ae7d5c06ab183893ed51f12edb0f73771c4bce0f685320a7385642b7fb46756268920e7358f0232c35633c73ef0690fdd1e5c7fd7a15f0ee27d7
diff --git a/dev-ruby/rubocop/rubocop-1.63.5.ebuild b/dev-ruby/rubocop/rubocop-1.63.5.ebuild
new file mode 100644
index 00000000..963a0342
--- /dev/null
+++ b/dev-ruby/rubocop/rubocop-1.63.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets config"
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby static code analyzer"
+HOMEPAGE="https://github.com/rubocop/rubocop"
+SRC_URI="https://github.com/rubocop/rubocop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/json-2.3:2
+ >=dev-ruby/language_server-protocol-3.17.0
+ >=dev-ruby/parallel-1.10:1
+ >=dev-ruby/parser-3.3.0.2
+ dev-ruby/rainbow:3
+ dev-ruby/regexp_parser:2
+ >=dev-ruby/rexml-3.2.5:3
+ >=dev-ruby/rubocop-ast-1.31.1:1
+ >=dev-ruby/ruby-progressbar-1.7:0
+ >=dev-ruby/unicode-display_width-2.4.0:2"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rubocop-performance dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -e '/pry/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid bundler spec
+ sed -e '/and the gem is bundled/,/^ end/ s:^:#:' \
+ -e '/when a file inherits from \(a url inheriting from a gem\|an unknown gem\)/ s/context/xcontext/' \
+ -e '/returns values from the gem config with local overrides/ s/it/xit/' \
+ -i spec/rubocop/config_loader_spec.rb || die
+ sed -i -e '/gem_versions_in_target/ s/describe/xdescribe/' spec/rubocop/config_spec.rb || die
+ sed -e '/when the extensions are loaded via inherit_gem/ s/context/xcontext/' \
+ -i spec/rubocop/config_obsoletion_spec.rb || die
+ sed -i -e '/bundler integration/,/^ end/ s:^:#:' spec/rubocop/cli_spec.rb || die
+ rm -f spec/rubocop/cli_spec.rb spec/rubocop/cli/suggest_extensions_spec.rb spec/rubocop/lockfile_spec.rb || die
+
+ # Avoid specs requiring rubocop-rake
+ sed -i -e '/compliance with rubocop/,/^ end/ s:^:#:' spec/rubocop/cop/generator_spec.rb || die
+
+ # Avoid specs requiring many rubocop extensions
+ rm -f spec/rubocop/version_spec.rb || die
+
+ # Avoid specs that are not functional and break too often in releases
+ sed -i -e '/has a unique contributor name/askip "too fragile"' spec/project_spec.rb || die
+
+ # Avoid spec that breaks when YJIT is enabled
+ sed -i -e '/logs the RuboCop version/ s/it/xit/' spec/rubocop/lsp/server_spec.rb || die
+
+ sed -e 's:/tmp/example:'"${TMPDIR}"'/example:' \
+ -e 's:/tmp/Gemfile:'"${TMPDIR}"'/Gemfile:' \
+ -i spec/rubocop/cop/team_spec.rb || die
+ sed -e 's:/tmp:'"${TMPDIR}"':' -i spec/rubocop/server/cli_spec.rb || die
+}