summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2024-07-15 09:05:07 +0200
committerHans de Graaff <hans@degraaff.org>2024-07-15 09:05:07 +0200
commit2a69525307b609ee774ddf6520ba02fa4de7c7e1 (patch)
treec61c5b176c879448576cf660895ac3cb787acc4e
parentdev-ruby/reverse_markdown: enable ruby33 (diff)
downloadgraaff-2a69525307b609ee774ddf6520ba02fa4de7c7e1.tar.gz
graaff-2a69525307b609ee774ddf6520ba02fa4de7c7e1.tar.bz2
graaff-2a69525307b609ee774ddf6520ba02fa4de7c7e1.zip
dev-ruby/solargraph: add 0.50.0
Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/solargraph/Manifest1
-rw-r--r--dev-ruby/solargraph/solargraph-0.50.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-ruby/solargraph/Manifest b/dev-ruby/solargraph/Manifest
index ae527a31..918b05ad 100644
--- a/dev-ruby/solargraph/Manifest
+++ b/dev-ruby/solargraph/Manifest
@@ -1 +1,2 @@
DIST solargraph-0.49.0.tar.gz 204998 BLAKE2B c9ec24123fc32d2156e44bffbc419015ebc46e8f56ddf4d6d89947e7c8846feb2e5b5f982ce5c332f937e7f7367a3429cca026893a1240860ba74e72249c005a SHA512 3e70e2c70f0b072352eeb9c153ff9547c12df230ade23094c6f3b724c69e3ab5225dd7e166136bc867725117c78d8d2dc02b1c95fdcaff99d095e39d96829466
+DIST solargraph-0.50.0.tar.gz 205733 BLAKE2B 2c3e5d1a69547a2d2d7908631e8dbc875aa16882c661b980b81dd8626309b46003ec58a9d0f24ce685030ca7667ed5f73a2d93ebd8bf15448eb55c9488a644f9 SHA512 9d9a8ac85f5241565ee317bdde9f6ed2c7e6a2e8d5b5b8eb52cb60d54c63b0dd8bb75d8a5bcc12e8085be108530049a82318593613aab90129ee1ae8b6f2508a
diff --git a/dev-ruby/solargraph/solargraph-0.50.0.ebuild b/dev-ruby/solargraph/solargraph-0.50.0.ebuild
new file mode 100644
index 00000000..70963d67
--- /dev/null
+++ b/dev-ruby/solargraph/solargraph-0.50.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="solargraph.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="IDE tools for code completion, inline documentation, and static analysis"
+HOMEPAGE="https://solargraph.org/"
+SRC_URI="https://github.com/castwide/solargraph/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc"
+
+ruby_add_rdepend "
+ >=dev-ruby/backport-1.2:0
+ dev-ruby/benchmark
+ dev-ruby/bundler:2
+ >=dev-ruby/diff-lcs-1.4:0
+ dev-ruby/e2mmap
+ >=dev-ruby/jaro_winkler-1.5:1
+ >=dev-ruby/kramdown-2.3:2
+ >=dev-ruby/kramdown-parser-gfm-1.1:1
+ >=dev-ruby/parser-3.0:0
+ =dev-ruby/rbs-3*
+ =dev-ruby/reverse_markdown-2*
+ >=dev-ruby/rubocop-1.38
+ dev-ruby/thor:1
+ dev-ruby/tilt:2
+ >=dev-ruby/yard-0.9.24:0
+"
+
+# public_suffix is listed as a development dependency but not actually used anywhere.
+ruby_add_bdepend "test? (
+ >=dev-ruby/webmock-3.6:3
+)"
+
+PATCHES=(
+ "${FILESDIR}/solargraph-0.49.0-rbs-3.patch"
+ "${FILESDIR}/solargraph-0.49.0-rbs-stdlib-spec.patch"
+)
+
+all_ruby_prepare() {
+ sed -i -e '/pry/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -e '/bundler/ s:^:#:' \
+ -e '/SIMPLECOV/,/end/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+ rm -f spec/api_map/bundler_methods_spec.rb spec/{documentor,yard_map}_spec.rb|| die
+
+ sed -e '/ignores undefined method calls from external sources/askip "Does not work with Gentoo installed package"' \
+ -i spec/type_checker/levels/strict_spec.rb || die
+}
+
+each_ruby_test() {
+ each_fakegem_test
+
+ # Remove cached gem installs in homedir since they will cause the
+ # next run to fail.
+ rm -rf "${HOME}/.local/share/gem" || die
+}