summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-05 20:38:32 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-05 20:38:32 +0100
commit817e3e253a77510a5d2d1f49028cf681dc4038be (patch)
tree28ec7b9419a1cee14b8119b4bfbcb515b17df691 /dev-python
parentdev-python/python-sjutils: no need for this anymore (diff)
downloadeva-817e3e253a77510a5d2d1f49028cf681dc4038be.tar.gz
eva-817e3e253a77510a5d2d1f49028cf681dc4038be.tar.bz2
eva-817e3e253a77510a5d2d1f49028cf681dc4038be.zip
dev-python/pylibtextcat: no need for this anymore
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylibtextcat/Manifest1
-rw-r--r--dev-python/pylibtextcat/files/pylibtextcat-0.2-includes.patch16
-rw-r--r--dev-python/pylibtextcat/files/pylibtextcat-0.2-library.patch11
-rw-r--r--dev-python/pylibtextcat/pylibtextcat-0.2.ebuild38
-rw-r--r--dev-python/pylibtextcat/pylibtextcat-9999.ebuild32
5 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/pylibtextcat/Manifest b/dev-python/pylibtextcat/Manifest
deleted file mode 100644
index 48e6bb7..0000000
--- a/dev-python/pylibtextcat/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pylibtextcat-0.2.tar.bz2 6308 RMD160 0914dbac221297867a6e9228f7f5125f6be40d94 SHA1 566fb3c89daa9311b55608e08e94ccf899129a3f SHA256 926dbfd088e7ce9b43d267cb0b5e78cee9296bf0191d7cc398ead45c99b6bba9
diff --git a/dev-python/pylibtextcat/files/pylibtextcat-0.2-includes.patch b/dev-python/pylibtextcat/files/pylibtextcat-0.2-includes.patch
deleted file mode 100644
index b88f2b2..0000000
--- a/dev-python/pylibtextcat/files/pylibtextcat-0.2-includes.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- libtextcat.c.old 2012-06-04 23:04:33.711326535 +0200
-+++ libtextcat.c 2012-06-04 23:04:46.422201930 +0200
-@@ -4,10 +4,10 @@
- #include <osdefs.h>
- #include <structmember.h>
-
--#include <libtextcat/textcat.h>
--#include <libtextcat/constants.h>
-+#include <libexttextcat/textcat.h>
-+#include <libexttextcat/constants.h>
- #ifdef _UTF8_
--#include <libtextcat/utf8misc.h>
-+#include <libexttextcat/utf8misc.h>
- #else
- #define utfstrlen(s) strlen(s)
- #endif
diff --git a/dev-python/pylibtextcat/files/pylibtextcat-0.2-library.patch b/dev-python/pylibtextcat/files/pylibtextcat-0.2-library.patch
deleted file mode 100644
index 671ac3f..0000000
--- a/dev-python/pylibtextcat/files/pylibtextcat-0.2-library.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.old 2012-06-04 23:08:38.449925901 +0200
-+++ setup.py 2012-06-04 23:08:22.666080824 +0200
-@@ -25,7 +25,7 @@
- if get_default_compiler() in ('cygwin', 'emx', 'mingw32', 'unix'):
- warnflags = ['-Wall', '-Wextra']
- compile_args.extend(warnflags)
--library = ['textcat']
-+library = ['exttextcat-1.0']
- extens=[Extension('textcat', c_files, extra_compile_args=compile_args, libraries=library, define_macros=version_define)]
-
- setup(
diff --git a/dev-python/pylibtextcat/pylibtextcat-0.2.ebuild b/dev-python/pylibtextcat/pylibtextcat-0.2.ebuild
deleted file mode 100644
index 698afd9..0000000
--- a/dev-python/pylibtextcat/pylibtextcat-0.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils eutils
-
-DESCRIPTION="Fast python port of arc90's readability tool"
-HOMEPAGE="https://github.com/buriy/python-readability"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="
- app-text/libexttextcat
-"
-RDEPEND="${COMMON_DEPEND}
- dev-python/lxml
- dev-python/chardet
-"
-DEPEND="${COMMON_DEPEND}
- dev-python/setuptools
-"
-
-src_prepare() {
- # Allow build with libexttextcat
- epatch "${FILESDIR}/${P}-includes.patch" \
- "${FILESDIR}/${P}-library.patch"
-
- distutils_src_prepare
-}
diff --git a/dev-python/pylibtextcat/pylibtextcat-9999.ebuild b/dev-python/pylibtextcat/pylibtextcat-9999.ebuild
deleted file mode 100644
index bc2a96b..0000000
--- a/dev-python/pylibtextcat/pylibtextcat-9999.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils bzr
-
-DESCRIPTION="Fast python port of arc90's readability tool"
-HOMEPAGE="https://github.com/bbqsrc/pylibtextcat"
-EBZR_REPO_URI="lp:pylibtextcat"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEPEND="
- app-text/libtextcat
-"
-RDEPEND="${COMMON_DEPEND}
- dev-python/lxml
- dev-python/chardet
-"
-DEPEND="${COMMON_DEPEND}
- dev-python/setuptools
-"