summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-11-09 20:37:31 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-11-09 20:37:31 +0000
commitcc533d67ea019faac30510d5d6fda1c5f2783ea1 (patch)
treef4ceb72528a957ed9fded8c512fa981bc1578001 /net-libs
parentFixed WANT_AUTOMAKE to 1.8 (diff)
downloaddrizzt-cc533d67ea019faac30510d5d6fda1c5f2783ea1.tar.gz
drizzt-cc533d67ea019faac30510d5d6fda1c5f2783ea1.tar.bz2
drizzt-cc533d67ea019faac30510d5d6fda1c5f2783ea1.zip
Added btg and dep (libtorrent_rb)
svn path=/; revision=29
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent_rb/Manifest8
-rw-r--r--net-libs/libtorrent_rb/files/digest-libtorrent_rb-0.103
-rw-r--r--net-libs/libtorrent_rb/libtorrent_rb-0.10.ebuild37
3 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/libtorrent_rb/Manifest b/net-libs/libtorrent_rb/Manifest
new file mode 100644
index 0000000..636a4b8
--- /dev/null
+++ b/net-libs/libtorrent_rb/Manifest
@@ -0,0 +1,8 @@
+DIST libtorrent-0.10.tar.gz 989448 RMD160 e8ebb573e93122291615524ed3aab50bafaf9e1b SHA1 8b31a4aecaf2f9469e3949939a81d6bfb4661c25 SHA256 b337eb174a26722ec4cdd4349e07bb5ef51eda7d8de1414c9d5ad5251c021edf
+EBUILD libtorrent_rb-0.10.ebuild 1074 RMD160 b75dd9665aee849ffddaaf5338306a015fb74d84 SHA1 e5da5a7878c29e2a479cfbee5f0bdbae28f48a6c SHA256 f9d5cd591d279b428a4650aefd7f79a4dbef25fb7b74e840684a8a677061b71b
+MD5 db74b34600c8caf6455e5adb4b8e40a9 libtorrent_rb-0.10.ebuild 1074
+RMD160 b75dd9665aee849ffddaaf5338306a015fb74d84 libtorrent_rb-0.10.ebuild 1074
+SHA256 f9d5cd591d279b428a4650aefd7f79a4dbef25fb7b74e840684a8a677061b71b libtorrent_rb-0.10.ebuild 1074
+MD5 a559f7d82585085ee128d60baae10639 files/digest-libtorrent_rb-0.10 247
+RMD160 3da973557b68342aabde57c699339ac5c1b188fb files/digest-libtorrent_rb-0.10 247
+SHA256 4a452c24d1b0d700e2036f8594f4d79a00493f8344518d174a0eae03bc29676b files/digest-libtorrent_rb-0.10 247
diff --git a/net-libs/libtorrent_rb/files/digest-libtorrent_rb-0.10 b/net-libs/libtorrent_rb/files/digest-libtorrent_rb-0.10
new file mode 100644
index 0000000..308310c
--- /dev/null
+++ b/net-libs/libtorrent_rb/files/digest-libtorrent_rb-0.10
@@ -0,0 +1,3 @@
+MD5 73de41c4782c120f56bce73d8f534d0b libtorrent-0.10.tar.gz 989448
+RMD160 e8ebb573e93122291615524ed3aab50bafaf9e1b libtorrent-0.10.tar.gz 989448
+SHA256 b337eb174a26722ec4cdd4349e07bb5ef51eda7d8de1414c9d5ad5251c021edf libtorrent-0.10.tar.gz 989448
diff --git a/net-libs/libtorrent_rb/libtorrent_rb-0.10.ebuild b/net-libs/libtorrent_rb/libtorrent_rb-0.10.ebuild
new file mode 100644
index 0000000..474515c
--- /dev/null
+++ b/net-libs/libtorrent_rb/libtorrent_rb-0.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_P=${P/_rb/}
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ local boost_libs
+ # If threads were used to build boost, the library files will have a suffix.
+ if built_with_use "dev-libs/boost" threads || use built_with_use "dev-libs/boost" threads-only ; then
+ boost_libs="--with-boost-date-time=mt --with-boost-filesystem=mt --with-boost-thread=mt --with-boost-regex=mt --with-boost-program_options=mt"
+ else
+ die "libtorrent_rb needs dev-libs/boost built with threads USE flag"
+ fi
+
+ econf $(use_enable debug) ${boost_libs} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README
+}