summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2012-07-18 11:06:05 -0400
committerDane Smith <c1pher@gentoo.org>2012-07-18 11:06:05 -0400
commit00c16078ba06a1c8ea3c69e995cb5d5c053b79b3 (patch)
treef4cdfb122fe58de7a32c0b4a964d7174f7e19fe3 /www-apps/indefero/indefero-1.3.2.ebuild
parentdrop unneded patch. (diff)
downloadc1pher-00c16078ba06a1c8ea3c69e995cb5d5c053b79b3.tar.gz
c1pher-00c16078ba06a1c8ea3c69e995cb5d5c053b79b3.tar.bz2
c1pher-00c16078ba06a1c8ea3c69e995cb5d5c053b79b3.zip
Fix deps. Add new version for testing.
Diffstat (limited to 'www-apps/indefero/indefero-1.3.2.ebuild')
-rw-r--r--www-apps/indefero/indefero-1.3.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/www-apps/indefero/indefero-1.3.2.ebuild b/www-apps/indefero/indefero-1.3.2.ebuild
new file mode 100644
index 0000000..54f1d62
--- /dev/null
+++ b/www-apps/indefero/indefero-1.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils webapp
+
+DESCRIPTION="An open source Google Code clone"
+HOMEPAGE="http://www.indefero.net/"
+SRC_URI="http://projects.ceondo.com/p/${PN}/downloads/get/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}
+ dev-lang/php[gd]
+ dev-php/PEAR-Console_Getopt
+ dev-php/PEAR-Mail
+ dev-php/PEAR-Mail_Mime
+ dev-php/pluf
+ "
+S="${WORKDIR}/${PN}"
+
+src_prepare(){
+ #Expect pluf to be installed in the normal location and adjust the index.php
+ #to be where we want it.
+ epatch "${FILESDIR}/${PN}-gentoo.diff"
+ cp "${FILESDIR}/dbsetup.sh" src/ || die
+ cp "${FILESDIR}/bootstrap.php" . || die
+ mv www/* . || die
+ rmdir www || die
+}
+
+src_compile(){ :; }
+
+src_install(){
+ webapp_src_preinst
+ rm COPYING INSTALL.mdtext release-script run-tests .gitignore \
+ .gitattributes Makefile phpunit.xml || die
+ dodoc doc/* NEWS.mdtext AUTHORS CONTRIBUTE.mdtext
+ rm -rf test doc NEWS.mdtext AUTHORS CONTRIBUTE.mdtext || die
+
+ mv src/IDF/conf/idf.php-dist src/IDF/conf/idf.php || die
+ mv src/IDF/conf/path.php-dist src/IDF/conf/path.php || die
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}/src/IDF/conf/idf.php"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-${PV}.txt"
+ webapp_src_install
+}
+
+pkg_postinst(){
+ elog "The postinstall document contains all of the information"
+ elog "needed to get ${PN} running."
+ webapp_pkg_postinst
+}