summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild')
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild
new file mode 100644
index 0000000..fea4f21
--- /dev/null
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.4.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_STANDARD="77 90 2003"
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/5"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+RDEPEND="sci-libs/netcdf"
+DEPEND="${RDEPEND}
+ dev-lang/cfortran
+ doc? ( app-doc/doxygen[dot] )
+"
+
+src_prepare() {
+ # use system cfortran
+ rm libsrc/cfortran.h || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --disable-extra-example-tests
+ --enable-f03
+ $(use_enable doc dot)
+ $(use_enable doc doxygen)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}