summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2015-11-19 00:01:27 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2015-11-19 00:01:27 +0000
commit0e61840bf6b259581c333d931b9cf90bcb1ce1a7 (patch)
tree846a7ff5b3ef2976e16557bf4923f1efcefa73a9
parentsci-libs/netcdf: version bump (diff)
downloadbicatali-0e61840bf6b259581c333d931b9cf90bcb1ce1a7.tar.gz
bicatali-0e61840bf6b259581c333d931b9cf90bcb1ce1a7.tar.bz2
bicatali-0e61840bf6b259581c333d931b9cf90bcb1ce1a7.zip
dev-python/netcdf4-python: version bump
Package-Manager: portage-2.2.25
-rw-r--r--dev-python/netcdf4-python/Manifest1
-rw-r--r--dev-python/netcdf4-python/metadata.xml18
-rw-r--r--dev-python/netcdf4-python/netcdf4-python-1.2.1.ebuild34
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/netcdf4-python/Manifest b/dev-python/netcdf4-python/Manifest
new file mode 100644
index 0000000..be7cf60
--- /dev/null
+++ b/dev-python/netcdf4-python/Manifest
@@ -0,0 +1 @@
+DIST netCDF4-1.2.1.tar.gz 663169 SHA256 3e0e71fc12af077a4737e75b6f421369e8170edc2cef0404d1164ae9ff38ef73 SHA512 05f419f7d80576843fb6c2ee7fb0d4f1be92861cb53024c71eac297f3a94bfcbd224470164174786ec9fcdd4081f2f4fc59cbcebf7a606c66d686776bc1cce8c WHIRLPOOL ae76ffdebe34b72660c8e4f8687f8389b46ab07480a61be8e86b41a9bc2c0b9f9d9974c22837d047d6ecc155264c1d2227cade51294bcfa121609b3ed253a531
diff --git a/dev-python/netcdf4-python/metadata.xml b/dev-python/netcdf4-python/metadata.xml
new file mode 100644
index 0000000..5d31d8f
--- /dev/null
+++ b/dev-python/netcdf4-python/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ netcdf4-python is a Python interface to the netCDF C library.
+ netCDF version 4 can read and write files in both the new netCDF 4
+ and the old netCDF 3 format, and can create files that are readable
+ by HDF5 clients. The API modelled after Scientific.IO.NetCDF, and
+ should be familiar to users of that module.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">netCDF4</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/netcdf4-python/netcdf4-python-1.2.1.ebuild b/dev-python/netcdf4-python/netcdf4-python-1.2.1.ebuild
new file mode 100644
index 0000000..ddef28a
--- /dev/null
+++ b/dev-python/netcdf4-python/netcdf4-python-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+MY_PN="netCDF4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python/numpy interface to the netCDF C library"
+HOMEPAGE="http://unidata.github.io/netcdf4-python"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy
+ sci-libs/hdf5
+ sci-libs/netcdf:=[hdf,hdf5]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ cd test || die
+ ${PYTHON} run_all.py || die
+}