summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/revoco/revoco-0.2.ebuild')
-rw-r--r--app-misc/revoco/revoco-0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/revoco/revoco-0.2.ebuild b/app-misc/revoco/revoco-0.2.ebuild
new file mode 100644
index 0000000..9ef26fa
--- /dev/null
+++ b/app-misc/revoco/revoco-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs linux-info
+
+DESCRIPTION="Tool for controlling Logitech MX Revolution mouses"
+HOMEPAGE="http://goron.de/~froese/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+
+CONFIG_CHECK="USB_HIDDEV"
+ERROR_USB_HIDDEN="You need to the CONFIG_USB_HIDDEV option turned on."
+
+S=${WORKDIR}
+
+src_compile() {
+ $(tc-getCC) -Wl,-z,now ${CFLAGS} ${LDFLAGS} ${FILESDIR}/${P}.c -o ${PN}
+}
+
+src_install() {
+ exeinto /usr/bin
+ exeopts -m 4711
+ doexe ${PN}
+}
+