summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ross <aross@gentoo.org>2006-09-29 07:27:02 +0000
committerAndrew Ross <aross@gentoo.org>2006-09-29 07:27:02 +0000
commit621a4163356de8a7232cd7e543e8fb731a0d06b9 (patch)
treeefbbd6ee795c769d84ac97453b15cf31d5ef4db8
parentImport of latest version currently in the main tree. (diff)
downloadaross-621a4163356de8a7232cd7e543e8fb731a0d06b9.tar.gz
aross-621a4163356de8a7232cd7e543e8fb731a0d06b9.tar.bz2
aross-621a4163356de8a7232cd7e543e8fb731a0d06b9.zip
Bud xen-tools-3.0.2-r4 from -r3 and remove support for unstable upstream, which belongs in an overlay.
svn path=/; revision=9
-rw-r--r--app-emulation/xen-tools/Manifest7
-rw-r--r--app-emulation/xen-tools/files/digest-xen-tools-3.0.2-r43
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild171
3 files changed, 181 insertions, 0 deletions
diff --git a/app-emulation/xen-tools/Manifest b/app-emulation/xen-tools/Manifest
index 3e0e11e..bbbded9 100644
--- a/app-emulation/xen-tools/Manifest
+++ b/app-emulation/xen-tools/Manifest
@@ -43,6 +43,13 @@ EBUILD xen-tools-3.0.2-r3.ebuild 5530 RMD160 fe932ebe8722970f5a433a0619552c6ec2f
MD5 11588a83ffd3177430efeca5cc668ba3 xen-tools-3.0.2-r3.ebuild 5530
RMD160 fe932ebe8722970f5a433a0619552c6ec2f93eaf xen-tools-3.0.2-r3.ebuild 5530
SHA256 cff3399ef7a791cafcf2053c00124ab56772b730ac8aa32a088ced857b011c1e xen-tools-3.0.2-r3.ebuild 5530
+EBUILD xen-tools-3.0.2-r4.ebuild 4957 RMD160 89a3fc0d823f0e325ae22a942dba5684388478de SHA1 f9afad19694049508ab1bd401e72a60069492bbe SHA256 ed1e893389c3dd8284536ece238214c3f387fa709c0fb05405c49ebba47bb093
+MD5 4f63ce57618a29ae97f0acf202b592ef xen-tools-3.0.2-r4.ebuild 4957
+RMD160 89a3fc0d823f0e325ae22a942dba5684388478de xen-tools-3.0.2-r4.ebuild 4957
+SHA256 ed1e893389c3dd8284536ece238214c3f387fa709c0fb05405c49ebba47bb093 xen-tools-3.0.2-r4.ebuild 4957
MD5 6618adc624bc8ab64af0f4555c33529a files/digest-xen-tools-3.0.2-r3 235
RMD160 ad3a1d2a82c40b0bca653431c2d7964809580e5e files/digest-xen-tools-3.0.2-r3 235
SHA256 274536fc8a3cb10fda114e533062b0dbddcda4ae15f52033a39b85785b221794 files/digest-xen-tools-3.0.2-r3 235
+MD5 6618adc624bc8ab64af0f4555c33529a files/digest-xen-tools-3.0.2-r4 235
+RMD160 ad3a1d2a82c40b0bca653431c2d7964809580e5e files/digest-xen-tools-3.0.2-r4 235
+SHA256 274536fc8a3cb10fda114e533062b0dbddcda4ae15f52033a39b85785b221794 files/digest-xen-tools-3.0.2-r4 235
diff --git a/app-emulation/xen-tools/files/digest-xen-tools-3.0.2-r4 b/app-emulation/xen-tools/files/digest-xen-tools-3.0.2-r4
new file mode 100644
index 0000000..724d092
--- /dev/null
+++ b/app-emulation/xen-tools/files/digest-xen-tools-3.0.2-r4
@@ -0,0 +1,3 @@
+MD5 544eab940a0734a55459d648e5c3b224 xen-3.0.2-src.tgz 4933621
+RMD160 34e4431a981891319f8a5ea0c3f604e7d8d7d7af xen-3.0.2-src.tgz 4933621
+SHA256 f18ffab16a457fa721d11933c75f8288f6958c88c2669857c7c11d5107ba2951 xen-3.0.2-src.tgz 4933621
diff --git a/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
new file mode 100644
index 0000000..6397214
--- /dev/null
+++ b/app-emulation/xen-tools/xen-tools-3.0.2-r4.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit mount-boot flag-o-matic distutils eutils multilib
+
+DESCRIPTION="Xend daemon and tools"
+HOMEPAGE="http://xen.sourceforge.net"
+SRC_URI="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-${PV}-src.tgz"
+S="${WORKDIR}/xen-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug screen custom-cflags hardened vnc sdl"
+
+CDEPEND="dev-lang/python
+ sys-libs/zlib
+ sdl? ( media-libs/libsdl )
+ vnc? ( media-libs/libsdl )"
+
+DEPEND="${CDEPEND}
+ sys-devel/gcc
+ dev-lang/perl
+ app-misc/pax-utils
+ doc? (
+ dev-tex/latex2html
+ media-gfx/transfig
+ )
+ vnc? ( net-libs/libvncserver )"
+
+RDEPEND="${CDEPEND}
+ >=app-emulation/xen-3.0.2
+ sys-apps/iproute2
+ net-misc/bridge-utils
+ screen? (
+ app-misc/screen
+ app-admin/logrotate
+ )
+ || ( sys-fs/udev sys-apps/hotplug )"
+
+PYTHON_MODNAME="xen grub"
+
+pkg_setup() {
+ if use vnc && ! use sdl ; then
+ ewarn "You have the 'vnc' USE flag set, but not 'sdl'."
+ ewarn "VNC functionality requires SDL support, so it"
+ ewarn "will be enabled anyway."
+ fi
+
+ if [[ "$(scanelf -s __guard -q `which python`)" ]] ; then
+ eerror "xend doesn't work when python is built with stack smashing protection (ssp)."
+ eerror "Please append the following to your CFLAGS and remerge python:"
+ eerror " '-fno-stack-protector -fno-stack-protector-all'"
+ die "python was built with stack smashing protection (ssp)"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+ # for some reason the xen gcc checks don't work on gentoo-hardened
+ if use hardened; then
+ HARDFLAGS="-nopie -fno-stack-protector -fno-stack-protector-all"
+ sed -e "s/CFLAGS :=/CFLAGS := ${HARDFLAGS}/" \
+ -i "${S}"/tools/firmware/hvmloader/Makefile \
+ "${S}"/tools/firmware/vmxassist/Makefile
+ fi
+
+ # Disable the 32bit-only vmxassist, if we are not on x86 and we don't support the x86 ABI
+ if ! use x86 && ! has x86 $(get_all_abis); then
+ sed -i -e "/SUBDIRS += vmxassist/d" "${S}"tools/firmware/Makefile
+ fi
+
+ # Fixes for hardened and amd64
+ epatch "${FILESDIR}"/${P}-bxclobber.patch
+ epatch "${FILESDIR}"/${P}-pushpop.patch
+
+ # Allow --as-needed LDFLAGS
+ epatch "${FILESDIR}/${P}"--as-needed.patch
+
+ # Fix upstream's broken test cases (bug #141233)
+ epatch "${FILESDIR}/${P}"-test-uuid.patch
+ epatch "${FILESDIR}/${P}"-test-xauthority.patch
+}
+
+src_compile() {
+ local myopt myconf
+ use debug && myopt="${myopt} debug=y"
+
+ myconf="${myconf} $(use_enable vnc)"
+ if use vnc ; then
+ myconf="${myconf} --enable-sdl"
+ else
+ myconf="${myconf} $(use_enable sdl)"
+ fi
+
+ use custom-cflags || unset CFLAGS
+ gcc-specs-ssp && append-flags -fno-stack-protector -fno-stack-protector-all
+
+ (cd tools/ioemu && econf ${myconf}) || die "configure failured"
+ emake -C tools ${myopt} || die "compile failed"
+
+ if use doc; then
+ sh ./docs/check_pkgs || die "package check failed"
+ emake -C docs || die "compiling docs failed"
+ fi
+
+ emake -C docs man-pages || die "make man-pages failed"
+}
+
+src_install() {
+ local myopt="XEN_PYTHON_NATIVE_INSTALL=1"
+
+ make DESTDIR="${D}" ${myopt} install-tools \
+ || die "install failed"
+
+ # Remove RedHat-specific stuff
+ rm -rf "${D}"/etc/sysconfig
+
+ if use doc; then
+ make DESTDIR="${D}" -C docs install || die "install docs failed"
+ # Rename doc/xen to the Gentoo-style doc/xen-x.y
+ mv "${D}"/usr/share/doc/{${PN},${PF}}
+ fi
+
+ doman docs/man?/*
+
+ newinitd "${FILESDIR}"/xend-init xend
+ newconfd "${FILESDIR}"/xendomains.confd xendomains
+ newinitd "${FILESDIR}"/xendomains.initd xendomains
+
+ if use screen; then
+ cat "${FILESDIR}"/xendomains-screen.confd >> "${D}"/etc/conf.d/xendomains
+ cp "${FILESDIR}"/xen-consoles.logrotate "${D}"/etc/xen/
+ keepdir /var/log/xen-consoles
+ fi
+
+ # xend expects these to exist
+ keepdir /var/run/xenstored /var/lib/xenstored /var/xen/dump
+}
+
+pkg_postinst() {
+ elog "Please visit the Xen and Gentoo wiki:"
+ elog "http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+
+ if ! built_with_use dev-lang/python ncurses; then
+ echo
+ ewarn "NB: Your dev-lang/python is built without USE=ncurses."
+ ewarn "Please rebuild python with USE=ncurses to make use of xenmon.py."
+ fi
+
+ if grep -qsF XENSV= "${ROOT}/etc/conf.d/xend"; then
+ echo
+ elog "xensv is broken upstream (Gentoo bug #142011)."
+ elog "Please remove '${ROOT%/}/etc/conf.d/xend', as it is no longer needed."
+ fi
+}