summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-mixer/xfce4-mixer-4.0.1.ebuild')
-rw-r--r--xfce-extra/xfce4-mixer/xfce4-mixer-4.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mixer/xfce4-mixer-4.0.1.ebuild b/xfce-extra/xfce4-mixer/xfce4-mixer-4.0.1.ebuild
new file mode 100644
index 000000000000..72abc56cd621
--- /dev/null
+++ b/xfce-extra/xfce4-mixer/xfce4-mixer-4.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mixer/xfce4-mixer-4.0.1.ebuild,v 1.1 2003/11/13 00:37:02 bcowan Exp $
+
+IUSE="alsa"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Xfce4 Mixer"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ alsa? ( media-libs/alsa-lib )
+ =xfce-base/xfce4-base-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use alsa && myconf="${myconf} --with-sound=alsa"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL COPYING README TODO
+}