summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfdesktop/xfdesktop-4.0.1.ebuild')
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/xfdesktop-4.0.1.ebuild b/xfce-base/xfdesktop/xfdesktop-4.0.1.ebuild
new file mode 100644
index 000000000000..d9dfe44284f4
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.0.1.ebuild,v 1.1 2003/11/13 00:28:16 bcowan Exp $
+
+IUSE="X"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Xfce4 desktop"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL COPYING README ChangeLog TODO
+}