summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch')
-rw-r--r--x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch36
1 files changed, 31 insertions, 5 deletions
diff --git a/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch
index 5392fa00d021..967abc4e2044 100644
--- a/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch
+++ b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch
@@ -1,8 +1,6 @@
-Index: compiz-plugins-extra-0.8.6/configure.ac
-===================================================================
---- compiz-plugins-extra-0.8.6.orig/configure.ac
-+++ compiz-plugins-extra-0.8.6/configure.ac
-@@ -136,9 +136,12 @@ AM_CONDITIONAL(THREED_PLUGIN, test "x$ha
+--- configure.ac
++++ configure.ac
+@@ -136,9 +136,12 @@
PKG_CHECK_MODULES(COMPIZMOUSEPOLL, compiz-mousepoll, [have_compiz_mousepoll=yes], [have_compiz_mousepoll=no])
AM_CONDITIONAL(SHOWMOUSE_PLUGIN, test "x$have_compiz_mousepoll" = "xyes")
@@ -17,3 +15,31 @@ Index: compiz-plugins-extra-0.8.6/configure.ac
AC_DEFINE(USE_NOTIFICATION, 1, [Build notification plugin])
fi
+--- src/notification/notification.c
++++ src/notification/notification.c
+@@ -21,6 +21,11 @@
+
+
+ #include <libnotify/notify.h>
++
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <string.h>
+@@ -103,7 +108,12 @@
+
+ n = notify_notification_new (logLevel,
+ message,
+- iconUri, NULL);
++ iconUri
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+
+ notify_notification_set_timeout (n, nd->timeout);
+