summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsnap/xsnap-1.4.4.ebuild')
-rw-r--r--x11-misc/xsnap/xsnap-1.4.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/xsnap/xsnap-1.4.4.ebuild b/x11-misc/xsnap/xsnap-1.4.4.ebuild
new file mode 100644
index 000000000000..ff0830355f4c
--- /dev/null
+++ b/x11-misc/xsnap/xsnap-1.4.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/xsnap-1.4.4.ebuild,v 1.1 2006/11/08 14:07:18 nelchael Exp $
+
+DESCRIPTION="Program to interactively take a 'snapshot' of a region of the screen"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/Xutils/${P}.tar.bz2"
+HOMEPAGE="ftp://ftp.ac-grenoble.fr/ge/Xutils/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ media-libs/libpng
+ media-libs/jpeg"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ app-text/rman
+ x11-misc/imake"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e 's,X11R6/,,g' "${S}/Imakefile"
+
+}
+
+src_compile() {
+
+ xmkmf || die "xmkmf failed"
+ make || die "make failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR=${D} install.man || die "make install.man failed"
+ dodoc README AUTHORS
+
+}