summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/alltray/alltray-0.54.ebuild')
-rw-r--r--x11-misc/alltray/alltray-0.54.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/alltray/alltray-0.54.ebuild b/x11-misc/alltray/alltray-0.54.ebuild
new file mode 100644
index 000000000000..c16a194c2ada
--- /dev/null
+++ b/x11-misc/alltray/alltray-0.54.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alltray/alltray-0.54.ebuild,v 1.1 2005/06/12 22:52:45 swegener Exp $
+
+DESCRIPTION="Dock any application into the system tray/notification area"
+HOMEPAGE="http://alltray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}"/${P}
+
+src_compile() {
+ # The --datadir and --sysconfdir options are needed to pass a check
+ econf \
+ --datadir='${prefix}/share' \
+ --sysconfdir='${prefix}/etc' \
+ || die "econf failed"
+ emake X_CFLAGS="-fPIC" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}