summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/Manifest4
-rw-r--r--x11-libs/vte/files/digest-vte-0.11.171
-rw-r--r--x11-libs/vte/vte-0.11.17.ebuild54
4 files changed, 64 insertions, 2 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 5e1b0b5bf1bd..3b20ef415bd5 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.104 2006/01/22 21:32:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.105 2006/01/29 18:05:29 allanonjl Exp $
+
+*vte-0.11.17 (29 Jan 2006)
+
+ 29 Jan 2006; John N. Laliberte <allanonjl@gentoo.org> +vte-0.11.17.ebuild:
+ new version. remove pkgconfig patch since it has been merged upstream.
22 Jan 2006; Markus Rothe <corsair@gentoo.org> vte-0.11.16-r1.ebuild:
Stable on ppc64
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index 60483ea30ad6..b640a0aba773 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -1,9 +1,10 @@
-MD5 b4f0cddd2bb11963b5039732ee9f0832 ChangeLog 12185
+MD5 4d698b272f180f3ef98403b3c9b0e0e7 ChangeLog 12364
MD5 41b41aaa36ba84805514d34f2d9b491f files/digest-vte-0.11.13-r2 64
MD5 d1ed443a14f417affb1932a7765c120c files/digest-vte-0.11.15 64
MD5 d1ed443a14f417affb1932a7765c120c files/digest-vte-0.11.15-r1 64
MD5 71c3b1aad083c8366c3501d857d9b622 files/digest-vte-0.11.16 64
MD5 71c3b1aad083c8366c3501d857d9b622 files/digest-vte-0.11.16-r1 64
+MD5 40760af0a48b104d3ac748c00bbbc0d6 files/digest-vte-0.11.17 64
MD5 f8d6220ac03de9b337c4b0ec5243f55f files/vte-0.11.13-memory_fix.patch 7661
MD5 5c662cb9664c2ba65b3623c2a14395bf files/vte-0.11.15-gdk-warnings.patch 632
MD5 3d000a15f9aa0f3c44eb22175d54c314 files/vte-0.11.16-pkgconfig_libs_fix.patch 564
@@ -15,3 +16,4 @@ MD5 cf8a45837bc6fdc036e01d2fe916a545 vte-0.11.15-r1.ebuild 1394
MD5 f389741157c2b244d42781121f5e597a vte-0.11.15.ebuild 1294
MD5 37a50f66076e9b23751db76d3b826262 vte-0.11.16-r1.ebuild 1348
MD5 c1bb4fc20b0ddfa11a4e7ba3a28e52e3 vte-0.11.16.ebuild 1297
+MD5 95da8c1da47577801924109107858ca5 vte-0.11.17.ebuild 1273
diff --git a/x11-libs/vte/files/digest-vte-0.11.17 b/x11-libs/vte/files/digest-vte-0.11.17
new file mode 100644
index 000000000000..174fdea9c7fd
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.11.17
@@ -0,0 +1 @@
+MD5 bbe9710eca23984c884426a5d915f6eb vte-0.11.17.tar.bz2 943578
diff --git a/x11-libs/vte/vte-0.11.17.ebuild b/x11-libs/vte/vte-0.11.17.ebuild
new file mode 100644
index 000000000000..32a2fc3b0d6a
--- /dev/null
+++ b/x11-libs/vte/vte-0.11.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.11.17.ebuild,v 1.1 2006/01/29 18:05:29 allanonjl Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Xft powered terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc python"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2.2
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.2 )
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.6 )
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+
+pkg_setup() {
+ G2CONF="$(use_enable debug debugging) $(use_enable python)"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}/src"
+
+ # Apply the, shift-<up,down> scroll one
+ # line at a time patch.
+ epatch ${FILESDIR}/${PN}-line-scroll.patch
+
+ cd "${S}"
+ # Resolve all symbols at execution time for gnome-pty-helper. See bug
+ # #91617.
+ epatch ${FILESDIR}/${PN}-no_lazy_bindings.patch
+
+ cd gnome-pty-helper
+ WANT_AUTOMAKE=1.9
+ aclocal || die "aclocal failed"
+ automake || die "automake failed"
+}