summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/mozilla-firefox/mozilla-firefox-2.0.ebuild')
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-2.0.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/www-client/mozilla-firefox/mozilla-firefox-2.0.ebuild b/www-client/mozilla-firefox/mozilla-firefox-2.0.ebuild
index cd03491062ab..8f4b15fc0b25 100644
--- a/www-client/mozilla-firefox/mozilla-firefox-2.0.ebuild
+++ b/www-client/mozilla-firefox/mozilla-firefox-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-2.0.ebuild,v 1.5 2006/10/25 22:55:17 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-2.0.ebuild,v 1.6 2006/10/31 15:46:21 cardoe Exp $
inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib fdo-mime mozextension autotools
@@ -221,9 +221,15 @@ src_install() {
install_mozilla_launcher_stub firefox "${MOZILLA_FIVE_HOME}"
# Install icon and .desktop for menu entry
- doicon "${FILESDIR}"/icon/firefox-icon.png
- newmenu "${FILESDIR}"/icon/mozillafirefox-1.5.desktop \
- mozillafirefox-2.0.desktop
+ if use mozbranding; then
+ doicon "${FILESDIR}"/icon/firefox-icon.png
+ newmenu "${FILESDIR}"/icon/mozillafirefox-1.5.desktop \
+ mozillafirefox-2.0.desktop
+ else
+ doicon "${FILESDIR}"/icon/firefox-icon-unbranded.png
+ newmenu "${FILESDIR}"/icon/mozillafirefox-1.5-unbranded.desktop \
+ mozillafirefox-2.0.desktop
+ fi
# Fix icons to look the same everywhere
insinto "${MOZILLA_FIVE_HOME}"/icons