summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/ncurses/files/ncurses-5.3-coreutils.patch')
-rw-r--r--sys-libs/ncurses/files/ncurses-5.3-coreutils.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-libs/ncurses/files/ncurses-5.3-coreutils.patch b/sys-libs/ncurses/files/ncurses-5.3-coreutils.patch
new file mode 100644
index 000000000000..94e9e5623542
--- /dev/null
+++ b/sys-libs/ncurses/files/ncurses-5.3-coreutils.patch
@@ -0,0 +1,42 @@
+diff -urN ncurses-5.3/configure ncurses-5.3.coretutils/configure
+--- ncurses-5.3/configure 2002-09-22 02:49:14.000000000 +0200
++++ ncurses-5.3.coretutils/configure 2004-01-11 16:40:25.690883976 +0200
+@@ -1963,7 +1963,7 @@
+ if test "$GCC" = yes ; then
+ echo "$as_me:1964: checking version of gcc" >&5
+ echo $ECHO_N "checking version of gcc... $ECHO_C" >&6
+- GCC_VERSION="`${CC} --version|head -1`"
++ GCC_VERSION="`${CC} --version|head -n 1`"
+ echo "$as_me:1967: result: $GCC_VERSION" >&5
+ echo "${ECHO_T}$GCC_VERSION" >&6
+ fi
+@@ -2850,7 +2850,7 @@
+ if test "$GXX" = yes; then
+ echo "$as_me:2851: checking version of g++" >&5
+ echo $ECHO_N "checking version of g++... $ECHO_C" >&6
+- GXX_VERSION="`${CXX-g++} --version|head -1`"
++ GXX_VERSION="`${CXX-g++} --version|head -n 1`"
+ echo "$as_me:2854: result: $GXX_VERSION" >&5
+ echo "${ECHO_T}$GXX_VERSION" >&6
+ case $GXX_VERSION in
+diff -urN ncurses-5.3/configure.in ncurses-5.3.coretutils/configure.in
+--- ncurses-5.3/configure.in 2002-09-15 02:11:28.000000000 +0200
++++ ncurses-5.3.coretutils/configure.in 2004-01-11 16:40:25.733877440 +0200
+@@ -83,7 +83,7 @@
+ GCC_VERSION=none
+ if test "$GCC" = yes ; then
+ AC_MSG_CHECKING(version of gcc)
+- GCC_VERSION="`${CC} --version|head -1`"
++ GCC_VERSION="`${CC} --version|head -n 1`"
+ AC_MSG_RESULT($GCC_VERSION)
+ fi
+
+@@ -158,7 +158,7 @@
+ GXX_VERSION=none
+ if test "$GXX" = yes; then
+ AC_MSG_CHECKING(version of g++)
+- GXX_VERSION="`${CXX-g++} --version|head -1`"
++ GXX_VERSION="`${CXX-g++} --version|head -n 1`"
+ AC_MSG_RESULT($GXX_VERSION)
+ case $GXX_VERSION in
+ 1*|2.[[0-6]]*)