summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/device-mapper/device-mapper-1.00.05.ebuild')
-rw-r--r--sys-libs/device-mapper/device-mapper-1.00.05.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-libs/device-mapper/device-mapper-1.00.05.ebuild b/sys-libs/device-mapper/device-mapper-1.00.05.ebuild
index 337a5cf735b4..9d1b55b0323c 100644
--- a/sys-libs/device-mapper/device-mapper-1.00.05.ebuild
+++ b/sys-libs/device-mapper/device-mapper-1.00.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/device-mapper/device-mapper-1.00.05.ebuild,v 1.1 2003/09/02 20:45:55 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/device-mapper/device-mapper-1.00.05.ebuild,v 1.2 2003/10/21 22:51:07 max Exp $
DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities."
HOMEPAGE="http://www.sistina.com/products_lvm.htm"
@@ -8,13 +8,13 @@ SRC_URI="ftp://ftp.sistina.com/pub/LVM2/${PN}/${PN}.${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
DEPEND="virtual/linux-sources"
S="${WORKDIR}/${PN}.${PV}"
-src_unpack() {
+pkg_setup() {
[ ! -e "/usr/src/linux/include/linux/dm-ioctl.h" ] && {
eerror
eerror "Your currently linked kernel (/usr/src/linux) hasn't"
@@ -22,15 +22,13 @@ src_unpack() {
eerror
die "kernel not patched for device mapper support"
}
-
- unpack ${A}
}
src_compile() {
econf
# parallel build doesn't work
- make || die "compile problem"
+ emake -j1 || die "compile problem"
}
src_install() {