summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/keepalived/keepalived-1.1.6.ebuild')
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.6.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-cluster/keepalived/keepalived-1.1.6.ebuild b/sys-cluster/keepalived/keepalived-1.1.6.ebuild
new file mode 100644
index 000000000000..587f24636f1d
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-1.1.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.6.ebuild,v 1.1 2004/02/23 18:00:05 iggy Exp $
+
+DESCRIPTION="The main goal of the keepalived project is to add a strong & robust keepalive facility to the Linux Virtual Server project."
+HOMEPAGE="http://keepalived.sourceforge.net"
+LICENSE="GPL-2"
+
+DEPEND="dev-libs/popt
+ sys-apps/iproute"
+
+SRC_URI="http://keepalived.sourceforge.net/software/${P}.tar.gz"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ local myconf
+
+ myconf="--prefix=/"
+
+ use debug && myconf="${myconf} --enable-debug"
+# use profile && myconf="${myconf} --enable-profile"
+
+ cd "${S}"
+ ./configure ${myconf} || die "configure failed"
+ emake || die "make failed (myconf=${myconf})"
+
+}
+
+src_install() {
+
+ cd "${S}"
+ einstall || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init-keepalived keepalived
+
+ dodoc doc/keepalived.conf.SYNOPSIS
+ doman doc/man/man*/*
+}
+
+pkg_postinst() {
+
+ einfo ""
+ einfo "If you want Linux Virtual Server support in keepalived then you must emerge an"
+ einfo "LVS patched kernel, compile with ipvs support either as a module or built into"
+ einfo "the kernel, emerge the ipvsadm userland tools, and reemerge keepalived."
+ einfo ""
+ einfo "For debug support add USE=\"debug\" to your /etc/make.conf"
+ einfo ""
+
+}