summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/syslinux/syslinux-2.11.ebuild')
-rw-r--r--sys-boot/syslinux/syslinux-2.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-boot/syslinux/syslinux-2.11.ebuild b/sys-boot/syslinux/syslinux-2.11.ebuild
new file mode 100644
index 000000000000..9d60533d85f2
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-2.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.11.ebuild,v 1.1 2004/12/04 21:51:09 iggy Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND="dev-lang/nasm
+ sys-fs/mtools"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ make INSTALLROOT=${D} install || die
+ dodoc README NEWS TODO *.doc memdisk/memdisk.doc
+}