summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub/grub-0.96-r1.ebuild')
-rw-r--r--sys-boot/grub/grub-0.96-r1.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/sys-boot/grub/grub-0.96-r1.ebuild b/sys-boot/grub/grub-0.96-r1.ebuild
index 534b309b75cc..b3f6b48386c5 100644
--- a/sys-boot/grub/grub-0.96-r1.ebuild
+++ b/sys-boot/grub/grub-0.96-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.4 2005/03/12 19:17:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.5 2005/03/15 23:39:52 eradicator Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -22,16 +22,18 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/bootloader"
pkg_setup() {
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "If you are on amd64, make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit objects!"
+ if use amd64; then
+ if ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "If you are on amd64, make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit objects!"
+ fi
+
+ ABI_ALLOW="x86"
+ ABI="x86"
fi
-
- ABI_ALLOW="x86"
- ABI="x86"
}
src_unpack() {