summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_ldap/ChangeLog7
-rw-r--r--sys-auth/pam_ldap/files/digest-pam_ldap-1823
-rw-r--r--sys-auth/pam_ldap/pam_ldap-182.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/sys-auth/pam_ldap/ChangeLog b/sys-auth/pam_ldap/ChangeLog
index 508509965585..d68263a98346 100644
--- a/sys-auth/pam_ldap/ChangeLog
+++ b/sys-auth/pam_ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_ldap
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/ChangeLog,v 1.25 2006/04/29 23:01:17 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/ChangeLog,v 1.26 2006/05/29 01:57:12 robbat2 Exp $
+
+*pam_ldap-182 (29 May 2006)
+
+ 29 May 2006; Robin H. Johnson <robbat2@gentoo.org> +pam_ldap-182.ebuild:
+ Version bump.
29 Apr 2006; Michael Hanselmann <hansmi@gentoo.org> pam_ldap-180.ebuild:
Stable on mips.
diff --git a/sys-auth/pam_ldap/files/digest-pam_ldap-182 b/sys-auth/pam_ldap/files/digest-pam_ldap-182
new file mode 100644
index 000000000000..241945803cd7
--- /dev/null
+++ b/sys-auth/pam_ldap/files/digest-pam_ldap-182
@@ -0,0 +1,3 @@
+MD5 08f78beb40ee62d4c60e9b21934ebb83 pam_ldap-182.tar.gz 127582
+RMD160 9cd5aebfe0ba8507ffaa10fa87658c3f7008fab2 pam_ldap-182.tar.gz 127582
+SHA256 50f886627f46f28c89276d588863b82c3179dcf47f9059f2921aa85453fb2773 pam_ldap-182.tar.gz 127582
diff --git a/sys-auth/pam_ldap/pam_ldap-182.ebuild b/sys-auth/pam_ldap/pam_ldap-182.ebuild
new file mode 100644
index 000000000000..4cc05a2bfc78
--- /dev/null
+++ b/sys-auth/pam_ldap/pam_ldap-182.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/pam_ldap-182.ebuild,v 1.1 2006/05/29 01:57:12 robbat2 Exp $
+
+inherit eutils pam
+
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/pam_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_unpack() {
+ unpack ${A}
+ #EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-176-fix-referral-tls.patch
+
+ cd ${S}
+ export WANT_AUTOCONF=2.5
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+ automake --add-missing || die "automake failed"
+}
+
+src_compile() {
+ econf --with-ldap-lib=openldap `use_enable ssl` || die
+ emake || die
+}
+
+src_install() {
+ dopammod pam_ldap.so
+
+ dodoc pam.conf ldap.conf ldapns.schema chsh chfn certutil
+ dodoc ChangeLog CVSVersionInfo.txt README AUTHORS ns-pwd-policy.schema
+ doman pam_ldap.5
+
+ docinto pam.d
+ dodoc pam.d/*
+}