summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/turbotail')
-rw-r--r--sys-apps/turbotail/ChangeLog7
-rw-r--r--sys-apps/turbotail/turbotail-0.3.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/sys-apps/turbotail/ChangeLog b/sys-apps/turbotail/ChangeLog
index c0c69d91525e..028c50ec49cd 100644
--- a/sys-apps/turbotail/ChangeLog
+++ b/sys-apps/turbotail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/turbotail
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.6 2008/05/25 18:34:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.7 2008/05/25 20:31:17 jer Exp $
+
+*turbotail-0.3 (25 May 2008)
+
+ 25 May 2008; Jeroen Roovers <jer@gentoo.org> +turbotail-0.3.ebuild:
+ Version bump (bug #138401, credit to Tim Harder for reporting).
25 May 2008; Jeroen Roovers <jer@gentoo.org> turbotail-0.2-r1.ebuild:
Marked ~hppa too.
diff --git a/sys-apps/turbotail/turbotail-0.3.ebuild b/sys-apps/turbotail/turbotail-0.3.ebuild
new file mode 100644
index 000000000000..a0cf8277c68a
--- /dev/null
+++ b/sys-apps/turbotail/turbotail-0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/turbotail-0.3.ebuild,v 1.1 2008/05/25 20:31:17 jer Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="drop-in replacement for 'tail' which uses the kernel DNOTIFY-api"
+HOMEPAGE="http://www.vanheusden.com/turbotail/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-admin/gamin"
+
+src_compile() {
+ $(tc-getCC) -DVERSION=\"${PV}\" ${PN}.c -o ${PN} || die "compile failed"
+}
+
+src_install() {
+ dobin turbotail || die "install failed"
+ dodoc readme.txt
+}