summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog9
-rw-r--r--sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.993
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.4.99.ebuild48
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 401e1aa6702f..8fe76b36798b 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcsc-lite
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.56 2007/10/13 16:04:37 alonbl Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.57 2008/01/09 13:26:54 alonbl Exp $
+
+*pcsc-lite-1.4.99 (09 Jan 2008)
+
+ 09 Jan 2008; Alon Bar-Lev <alonbl@gentoo.org> +pcsc-lite-1.4.99.ebuild:
+ Version bump
13 Oct 2007; Alon Bar-Lev <alonbl@gentoo.org> pcsc-lite-1.4.4.ebuild:
Modify docs installed, bug#195712, requested by Mart Raudsepp
diff --git a/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.99 b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.99
new file mode 100644
index 000000000000..7e140fccdc95
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.99
@@ -0,0 +1,3 @@
+MD5 16c59b54edde9fa466c0e1f0eb86fd61 pcsc-lite-1.4.99.tar.gz 637727
+RMD160 689d99ae26a13dc78856670b0deafbd5fed517ab pcsc-lite-1.4.99.tar.gz 637727
+SHA256 630adc2e9b62168c9735395c8f39c63284112e431ca6f550b06d97d37edfc519 pcsc-lite-1.4.99.tar.gz 637727
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.4.99.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.4.99.ebuild
new file mode 100644
index 000000000000..9ef3173aa78d
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.4.99.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.4.99.ebuild,v 1.1 2008/01/09 13:26:54 alonbl Exp $
+
+inherit multilib
+
+STUPID_NUM="2257"
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static debug"
+
+RDEPEND="!static? ( dev-libs/libusb )"
+DEPEND="dev-libs/libusb
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ --enable-muscledropdir="/usr/share/pcsc/services" \
+ --enable-runpid="/var/run/pcscd.pid" \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS DRIVERS HELP README SECURITY ChangeLog
+ prepalldocs
+
+ newinitd "${FILESDIR}/pcscd-init" pcscd
+ newconfd "${FILESDIR}/pcscd-confd" pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --library libpcsclite.so.0'"
+}