summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/ChangeLog7
-rw-r--r--sys-apps/help2man/help2man-1.39.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/help2man/ChangeLog b/sys-apps/help2man/ChangeLog
index 951b35dc7566..dbd88f1c332f 100644
--- a/sys-apps/help2man/ChangeLog
+++ b/sys-apps/help2man/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/help2man
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.58 2011/02/28 23:42:14 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.59 2011/03/03 01:31:21 vapier Exp $
+
+*help2man-1.39.1 (03 Mar 2011)
+
+ 03 Mar 2011; Mike Frysinger <vapier@gentoo.org> +help2man-1.39.1.ebuild:
+ Version bump #357143 by Arfrever Frehtes Taifersar Arahesis.
28 Feb 2011; Brent Baude <ranger@gentoo.org> help2man-1.38.2.ebuild:
stable ppc64, bug 350091
diff --git a/sys-apps/help2man/help2man-1.39.1.ebuild b/sys-apps/help2man/help2man-1.39.1.ebuild
new file mode 100644
index 000000000000..ffa71fd9b709
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.39.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.39.1.ebuild,v 1.1 2011/03/03 01:31:21 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="http://www.gnu.org/software/help2man"
+SRC_URI="mirror://gnu/help2man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls elibc_glibc"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( nls? (
+ dev-perl/Locale-gettext
+ >=sys-devel/gettext-0.12.1-r1
+ ) )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.36.4-respect-LDFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-1.38.4-linguas.patch
+}
+
+src_configure() {
+ local myconf
+ use elibc_glibc \
+ && myconf="${myconf} $(use_enable nls)" \
+ || myconf="${myconf} --disable-nls"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README THANKS
+}