summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/darwin-miscutils')
-rw-r--r--sys-apps/darwin-miscutils/ChangeLog45
-rw-r--r--sys-apps/darwin-miscutils/darwin-miscutils-4-r1.ebuild106
-rw-r--r--sys-apps/darwin-miscutils/darwin-miscutils-5-r1.ebuild143
-rw-r--r--sys-apps/darwin-miscutils/darwin-miscutils-6.ebuild141
-rw-r--r--sys-apps/darwin-miscutils/files/darwin-miscutils-5-error.patch14
-rw-r--r--sys-apps/darwin-miscutils/files/darwin-miscutils-5-stdlib.patch20
-rw-r--r--sys-apps/darwin-miscutils/files/darwin-miscutils-5-w.patch10
-rw-r--r--sys-apps/darwin-miscutils/metadata.xml5
8 files changed, 484 insertions, 0 deletions
diff --git a/sys-apps/darwin-miscutils/ChangeLog b/sys-apps/darwin-miscutils/ChangeLog
new file mode 100644
index 000000000000..89ba00a949a2
--- /dev/null
+++ b/sys-apps/darwin-miscutils/ChangeLog
@@ -0,0 +1,45 @@
+# ChangeLog for sys-apps/darwin-miscutils
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/darwin-miscutils/ChangeLog,v 1.1 2009/06/21 13:31:36 grobian Exp $
+
+*darwin-miscutils-6 (19 Jun 2008)
+
+ 19 Jun 2008; Fabian Groffen <grobian@gentoo.org>
+ +darwin-miscutils-6.ebuild:
+ Version bump based on the sources of OSX 10.5.3
+
+*darwin-miscutils-5-r1 (02 Feb 2008)
+*darwin-miscutils-4-r1 (02 Feb 2008)
+
+ 02 Feb 2008; Fabian Groffen <grobian@gentoo.org>
+ -darwin-miscutils-4.ebuild, +darwin-miscutils-4-r1.ebuild,
+ -darwin-miscutils-5.ebuild, +darwin-miscutils-5-r1.ebuild:
+ No longer install rpcgen, since this tool is tightly associated to the OS it
+ runs on. In short, the Leopard version breaks on Tiger and vice versa.
+
+*darwin-miscutils-4 (14 Oct 2007)
+
+ 14 Oct 2007; Fabian Groffen <grobian@gentoo.org>
+ -darwin-miscutils-3.ebuild, +darwin-miscutils-4.ebuild:
+ Add some tools of developer_cmds, to have rpcgen and unifdef
+
+*darwin-miscutils-3 (17 Aug 2007)
+
+ 17 Aug 2007; Elias Pipping <pipping@gentoo.org>
+ -darwin-miscutils-2.ebuild, +darwin-miscutils-3.ebuild:
+ update to use latest version of shell_cmds, update header, fix typo
+
+*darwin-miscutils-2 (15 Dec 2006)
+
+ 15 Dec 2006; Fabian Groffen <grobian@gentoo.org>
+ +darwin-miscutils-2.ebuild, -darwin-miscutils-18.ebuild:
+ New version with extra utilities from shell_cmds: alias apply getopt
+ hostname jot kill killall lastcomm renice script shlock su time w
+ whereis. Changed version scheme to be Gentoo specific, as this package
+ is a selection of programs missing in coreutils. findutils, etc.
+
+ 9 Nov 2006; Fabian Groffen <grobian@gentoo.org> :
+
+ Initial import of darwin-miscutils, a package with the tools found in
+ Darwin: cal, calendar, leave, lock, units.
+
diff --git a/sys-apps/darwin-miscutils/darwin-miscutils-4-r1.ebuild b/sys-apps/darwin-miscutils/darwin-miscutils-4-r1.ebuild
new file mode 100644
index 000000000000..de5d41ef25c2
--- /dev/null
+++ b/sys-apps/darwin-miscutils/darwin-miscutils-4-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/darwin-miscutils/darwin-miscutils-4-r1.ebuild,v 1.1 2009/06/21 13:31:36 grobian Exp $
+
+inherit toolchain-funcs
+
+MISC_VER=18
+SHELL_VER=81
+DEV_VER=39
+
+DESCRIPTION="Miscellaneous commands used on Darwin/Mac OS X systems"
+HOMEPAGE="http://www.opensource.apple.com/"
+SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/misc_cmds-${MISC_VER}.tar.gz
+ http://www.opensource.apple.com/darwinsource/tarballs/other/shell_cmds-${SHELL_VER}.tar.gz
+ http://www.opensource.apple.com/darwinsource/tarballs/other/developer_cmds-${DEV_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_compile() {
+ local TS=${S}/misc_cmds-${MISC_VER}
+ # tsort is provided by coreutils
+ for t in cal leave lock units calendar; do
+ cd "${TS}/${t}"
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -o ${t}" *.c
+ $(tc-getCC) -o ${t} *.c || die "failed to compile $t"
+ done
+
+ TS=${S}/shell_cmds-${SHELL_VER}
+ # only pick those tools not provided by coreutils, findutils
+ for t in \
+ alias apply getopt hostname jot kill killall \
+ lastcomm renice script shlock time whereis;
+ do
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -o ${t} ${t}.c"
+ cd "${TS}/${t}"
+ $(tc-getCC) -o ${t} ${t}.c || die "failed to compile $t"
+ done
+ cd "${TS}/su"
+ echo "in ${TS}/su:"
+ echo "$(tc-getCC) -lpam -o su su.c"
+ $(tc-getCC) -lpam -o su su.c || die "failed to compile su"
+ cd "${TS}/w"
+ echo "in ${TS}/w:"
+ echo "$(tc-getCC) -DSUCKAGE -lresolv -o w w.c pr_time.c proc_compare.c"
+ $(tc-getCC) -DSUCKAGE -lresolv -o w w.c pr_time.c proc_compare.c \
+ || die "failed to compile w"
+
+ TS=${S}/developer_cmds-${DEV_VER}
+ # only pick those tools that do not conflict (no ctags and indent)
+ # do not install lorder, mkdep and vgrind as they are a non-prefix-aware
+ # shell scripts
+ # don't install rpcgen, as it is heavily related to the OS it runs
+ # on (and this is the Tiger version)
+ for t in asa error hexdump unifdef what ; do
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -o ${t}" *.c
+ cd "${TS}/${t}"
+ sed -i -e '/^__FBSDID/d' *.c
+ $(tc-getCC) -o ${t} *.c || die "failed to compile $t"
+ done
+}
+
+src_install() {
+ local ED=${ED-${D}}
+
+ mkdir -p "${ED}"/bin
+ mkdir -p "${ED}"/usr/bin
+
+ local TS=${S}/misc_cmds-${MISC_VER}
+ for t in cal leave lock units calendar ; do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+
+ TS=${S}/shell_cmds-${SHELL_VER}
+ for t in \
+ alias apply getopt jot killall lastcomm \
+ renice script shlock su time w whereis;
+ do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ [[ -f "${TS}/${t}/${t}.1" ]] && doman "${TS}/${t}/${t}.1"
+ [[ -f "${TS}/${t}/${t}.8" ]] && doman "${TS}/${t}/${t}.8"
+ done
+ cp "${TS}/w/w" "${ED}"/usr/bin/uptime
+ doman "${TS}/w/uptime.1"
+ for t in hostname kill; do
+ cp "${TS}/${t}/${t}" "${ED}"/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+
+ TS=${S}/developer_cmds-${DEV_VER}
+ for t in asa error hexdump unifdef what ; do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+}
diff --git a/sys-apps/darwin-miscutils/darwin-miscutils-5-r1.ebuild b/sys-apps/darwin-miscutils/darwin-miscutils-5-r1.ebuild
new file mode 100644
index 000000000000..4ab483bdc7f8
--- /dev/null
+++ b/sys-apps/darwin-miscutils/darwin-miscutils-5-r1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/darwin-miscutils/darwin-miscutils-5-r1.ebuild,v 1.1 2009/06/21 13:31:36 grobian Exp $
+
+inherit toolchain-funcs eutils
+
+MISC_VER=23
+SHELL_VER=118
+DEV_VER=48
+
+DESCRIPTION="Miscellaneous commands used on Darwin/Mac OS X systems"
+HOMEPAGE="http://www.opensource.apple.com/"
+SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/misc_cmds-${MISC_VER}.tar.gz
+ http://www.opensource.apple.com/darwinsource/tarballs/other/shell_cmds-${SHELL_VER}.tar.gz
+ http://www.opensource.apple.com/darwinsource/tarballs/other/developer_cmds-${DEV_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-w.patch
+ epatch "${FILESDIR}"/${P}-error.patch
+ epatch "${FILESDIR}"/${P}-stdlib.patch
+}
+
+src_compile() {
+ local TS=${S}/misc_cmds-${MISC_VER}
+ # tsort is provided by coreutils
+ for t in leave units calendar; do
+ cd "${TS}/${t}"
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -o ${t}" *.c
+ $(tc-getCC) -o ${t} *.c || die "failed to compile $t"
+ done
+ # compile cal separately
+ cd "${TS}/ncal"
+ echo "in ${TS}/ncal:"
+ local flags
+ flags[0]=-I.
+ flags[1]=-D__FBSDID=__RCSID
+ flags[2]=-Wsystem-headers
+ echo "$(tc-getCC) ${flags[@]} -c calendar.c"
+ $(tc-getCC) ${flags[@]} -c calendar.c || die "failed to compile cal"
+ echo "$(tc-getCC) ${flags[@]} -c easter.c"
+ $(tc-getCC) ${flags[@]} -c easter.c || die "failed to compile cal"
+ echo "$(tc-getCC) ${flags[@]} -c ncal.c"
+ $(tc-getCC) ${flags[@]} -c ncal.c || die "failed to compile cal"
+ echo "$(tc-getCC) ${flags[@]} -o cal calendar.o easter.o ncal.o"
+ $(tc-getCC) ${flags[@]} -o cal calendar.o easter.o ncal.o || die "failed to compile cal"
+
+ TS=${S}/shell_cmds-${SHELL_VER}
+ # only pick those tools not provided by coreutils, findutils
+ for t in \
+ alias apply getopt hostname jot kill \
+ lastcomm renice shlock time whereis;
+ do
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -o ${t} ${t}.c"
+ cd "${TS}/${t}"
+ $(tc-getCC) -o ${t} ${t}.c || die "failed to compile $t"
+ done
+ # script and killall need additonal flags
+ for t in \
+ killall script
+ do
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -D__FBSDID=__RCSID -o ${t} ${t}.c"
+ cd "${TS}/${t}"
+ $(tc-getCC) -D__FBSDID=__RCSID -o ${t} ${t}.c || die "failed to compile $t"
+ done
+ cd "${TS}/su"
+ echo "in ${TS}/su:"
+ echo "$(tc-getCC) -lpam -o su su.c"
+ $(tc-getCC) -lpam -o su su.c || die "failed to compile su"
+ cd "${TS}/w"
+ echo "in ${TS}/w:"
+ echo "$(tc-getCC) -DHAVE_UTMPX=1 -lresolv -o w w.c pr_time.c proc_compare.c"
+ $(tc-getCC) -DHAVE_UTMPX=1 -lresolv -o w w.c pr_time.c proc_compare.c \
+ || die "failed to compile w"
+
+ TS=${S}/developer_cmds-${DEV_VER}
+ # only pick those tools that do not conflict (no ctags and indent)
+ # do not install lorder, mkdep and vgrind as they are a non-prefix-aware
+ # shell scripts
+ # don't install rpcgen, as it is heavily related to the OS it runs
+ # on (and this is the Leopard version)
+ for t in asa error hexdump unifdef what ; do
+ echo "in ${TS}/${t}:"
+ cd "${TS}/${t}"
+ sed -i -e '/^__FBSDID/d' *.c
+ echo "$(tc-getCC) -o ${t}" *.c
+ $(tc-getCC) -o ${t} *.c || die "failed to compile $t"
+ done
+}
+
+src_install() {
+ local ED=${ED-${D}}
+
+ mkdir -p "${ED}"/bin
+ mkdir -p "${ED}"/usr/bin
+
+ local TS=${S}/misc_cmds-${MISC_VER}
+ for t in leave units calendar ; do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+ # copy cal separately
+ cp "${TS}/ncal/cal" "${ED}"/usr/bin/
+ dosym /usr/bin/cal /usr/bin/ncal
+ doman "${TS}/ncal/ncal.1"
+ dosym /usr/share/man/man1/ncal.1 /usr/share/man/man1/cal.1
+
+ TS=${S}/shell_cmds-${SHELL_VER}
+ for t in \
+ alias apply getopt jot killall lastcomm \
+ renice script shlock su time w whereis;
+ do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ [[ -f "${TS}/${t}/${t}.1" ]] && doman "${TS}/${t}/${t}.1"
+ [[ -f "${TS}/${t}/${t}.8" ]] && doman "${TS}/${t}/${t}.8"
+ done
+ cp "${TS}/w/w" "${ED}"/usr/bin/uptime
+ doman "${TS}/w/uptime.1"
+ for t in hostname kill; do
+ cp "${TS}/${t}/${t}" "${ED}"/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+
+ TS=${S}/developer_cmds-${DEV_VER}
+ for t in asa error hexdump unifdef what ; do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+}
diff --git a/sys-apps/darwin-miscutils/darwin-miscutils-6.ebuild b/sys-apps/darwin-miscutils/darwin-miscutils-6.ebuild
new file mode 100644
index 000000000000..1e1caa1ddfa8
--- /dev/null
+++ b/sys-apps/darwin-miscutils/darwin-miscutils-6.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/darwin-miscutils/darwin-miscutils-6.ebuild,v 1.1 2009/06/21 13:31:36 grobian Exp $
+
+inherit toolchain-funcs eutils
+
+MISC_VER=23
+SHELL_VER=118
+DEV_VER=49
+
+DESCRIPTION="Miscellaneous commands used on Darwin/Mac OS X systems"
+HOMEPAGE="http://www.opensource.apple.com/"
+SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/misc_cmds-${MISC_VER}.tar.gz
+ http://www.opensource.apple.com/darwinsource/tarballs/other/shell_cmds-${SHELL_VER}.tar.gz
+ http://www.opensource.apple.com/darwinsource/tarballs/other/developer_cmds-${DEV_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-5-w.patch
+ epatch "${FILESDIR}"/${PN}-5-stdlib.patch
+ cd "${S}"/developer_cmds-${DEV_VER}
+ epatch "${FILESDIR}"/${PN}-5-error.patch
+}
+
+src_compile() {
+ local TS=${S}/misc_cmds-${MISC_VER}
+ # tsort is provided by coreutils
+ for t in leave units calendar; do
+ cd "${TS}/${t}"
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -o ${t}" *.c
+ $(tc-getCC) -o ${t} *.c || die "failed to compile $t"
+ done
+ # compile cal separately
+ cd "${TS}/ncal"
+ echo "in ${TS}/ncal:"
+ local flags
+ flags[0]=-I.
+ flags[1]=-D__FBSDID=__RCSID
+ flags[2]=-Wsystem-headers
+ echo "$(tc-getCC) ${flags[@]} -c calendar.c"
+ $(tc-getCC) ${flags[@]} -c calendar.c || die "failed to compile cal"
+ echo "$(tc-getCC) ${flags[@]} -c easter.c"
+ $(tc-getCC) ${flags[@]} -c easter.c || die "failed to compile cal"
+ echo "$(tc-getCC) ${flags[@]} -c ncal.c"
+ $(tc-getCC) ${flags[@]} -c ncal.c || die "failed to compile cal"
+ echo "$(tc-getCC) ${flags[@]} -o cal calendar.o easter.o ncal.o"
+ $(tc-getCC) ${flags[@]} -o cal calendar.o easter.o ncal.o || die "failed to compile cal"
+
+ TS=${S}/shell_cmds-${SHELL_VER}
+ # only pick those tools not provided by coreutils, findutils
+ for t in \
+ alias apply getopt hostname jot kill \
+ lastcomm renice shlock time whereis;
+ do
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -o ${t} ${t}.c"
+ cd "${TS}/${t}"
+ $(tc-getCC) -o ${t} ${t}.c || die "failed to compile $t"
+ done
+ # script and killall need additonal flags
+ for t in \
+ killall script
+ do
+ echo "in ${TS}/${t}:"
+ echo "$(tc-getCC) -D__FBSDID=__RCSID -o ${t} ${t}.c"
+ cd "${TS}/${t}"
+ $(tc-getCC) -D__FBSDID=__RCSID -o ${t} ${t}.c || die "failed to compile $t"
+ done
+ cd "${TS}/su"
+ echo "in ${TS}/su:"
+ echo "$(tc-getCC) -lpam -o su su.c"
+ $(tc-getCC) -lpam -o su su.c || die "failed to compile su"
+ cd "${TS}/w"
+ echo "in ${TS}/w:"
+ echo "$(tc-getCC) -DHAVE_UTMPX=1 -lresolv -o w w.c pr_time.c proc_compare.c"
+ $(tc-getCC) -DHAVE_UTMPX=1 -lresolv -o w w.c pr_time.c proc_compare.c \
+ || die "failed to compile w"
+
+ TS=${S}/developer_cmds-${DEV_VER}
+ # only pick those tools that do not conflict (no ctags and indent)
+ # do not install lorder, mkdep and vgrind as they are a non-prefix-aware
+ # shell scripts
+ # don't install rpcgen, as it is heavily related to the OS it runs
+ # on (and this is the Leopard version)
+ for t in asa error hexdump unifdef what ; do
+ echo "in ${TS}/${t}:"
+ cd "${TS}/${t}"
+ sed -i -e '/^__FBSDID/d' *.c
+ echo "$(tc-getCC) -o ${t}" *.c
+ $(tc-getCC) -o ${t} *.c || die "failed to compile $t"
+ done
+}
+
+src_install() {
+ local ED=${ED-${D}}
+
+ mkdir -p "${ED}"/bin
+ mkdir -p "${ED}"/usr/bin
+
+ local TS=${S}/misc_cmds-${MISC_VER}
+ for t in leave units calendar ; do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+ # copy cal separately
+ cp "${TS}/ncal/cal" "${ED}"/usr/bin/
+ dosym /usr/bin/cal /usr/bin/ncal
+ doman "${TS}/ncal/ncal.1"
+ dosym /usr/share/man/man1/ncal.1 /usr/share/man/man1/cal.1
+
+ TS=${S}/shell_cmds-${SHELL_VER}
+ for t in \
+ alias apply getopt jot killall lastcomm \
+ renice script shlock su time w whereis;
+ do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ [[ -f "${TS}/${t}/${t}.1" ]] && doman "${TS}/${t}/${t}.1"
+ [[ -f "${TS}/${t}/${t}.8" ]] && doman "${TS}/${t}/${t}.8"
+ done
+ cp "${TS}/w/w" "${ED}"/usr/bin/uptime
+ doman "${TS}/w/uptime.1"
+ for t in hostname kill; do
+ cp "${TS}/${t}/${t}" "${ED}"/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+
+ TS=${S}/developer_cmds-${DEV_VER}
+ for t in asa error hexdump unifdef what ; do
+ cp "${TS}/${t}/${t}" "${ED}"/usr/bin/
+ doman "${TS}/${t}/${t}.1"
+ done
+}
diff --git a/sys-apps/darwin-miscutils/files/darwin-miscutils-5-error.patch b/sys-apps/darwin-miscutils/files/darwin-miscutils-5-error.patch
new file mode 100644
index 000000000000..391dceb39188
--- /dev/null
+++ b/sys-apps/darwin-miscutils/files/darwin-miscutils-5-error.patch
@@ -0,0 +1,14 @@
+--- developer_cmds-48/error/error.h
++++ developer_cmds-48/error/error.h
+@@ -194,11 +194,7 @@
+ */
+ extern int nerrors;
+ extern Eptr er_head;
+-#ifdef __APPLE__
+-__private_extern__
+-#else
+ extern
+-#endif
+ Eptr *errors;
+ /*
+ * Resources for each of the files mentioned
diff --git a/sys-apps/darwin-miscutils/files/darwin-miscutils-5-stdlib.patch b/sys-apps/darwin-miscutils/files/darwin-miscutils-5-stdlib.patch
new file mode 100644
index 000000000000..0605310bff42
--- /dev/null
+++ b/sys-apps/darwin-miscutils/files/darwin-miscutils-5-stdlib.patch
@@ -0,0 +1,20 @@
+--- misc_cmds-23/leave/leave.c
++++ misc_cmds-23/leave/leave.c
+@@ -34,6 +34,7 @@
+ */
+
+ #include <sys/cdefs.h>
++#include <stdlib.h>
+ #ifndef lint
+ __COPYRIGHT("@(#) Copyright (c) 1980, 1988, 1993\n\
+ The Regents of the University of California. All rights reserved.\n");
+--- shell_cmds-118/alias/alias.c
++++ shell_cmds-118/alias/alias.c
+@@ -3,6 +3,7 @@
+ the shell scripts. It does not lead to any deliverable. Do not remove this
+ file from this (..../shell_cmds/alias) directory.
+ */
++#include <stdlib.h>
+ int main()
+ {
+ exit(0);
diff --git a/sys-apps/darwin-miscutils/files/darwin-miscutils-5-w.patch b/sys-apps/darwin-miscutils/files/darwin-miscutils-5-w.patch
new file mode 100644
index 000000000000..f6db3753d930
--- /dev/null
+++ b/sys-apps/darwin-miscutils/files/darwin-miscutils-5-w.patch
@@ -0,0 +1,10 @@
+--- shell_cmds-118/w/w.c
++++ shell_cmds-118/w/w.c
+@@ -75,7 +75,6 @@
+ #include <kvm.h>
+ #endif
+ #include <langinfo.h>
+-#include <libutil.h>
+ #include <limits.h>
+ #include <locale.h>
+ #include <netdb.h>
diff --git a/sys-apps/darwin-miscutils/metadata.xml b/sys-apps/darwin-miscutils/metadata.xml
new file mode 100644
index 000000000000..925cf70da957
--- /dev/null
+++ b/sys-apps/darwin-miscutils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>apple</herd>
+</pkgmetadata>