summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/spin')
-rw-r--r--sci-mathematics/spin/ChangeLog9
-rw-r--r--sci-mathematics/spin/files/spin-font-size.patch47
-rw-r--r--sci-mathematics/spin/spin-5.2.5-r1.ebuild55
3 files changed, 110 insertions, 1 deletions
diff --git a/sci-mathematics/spin/ChangeLog b/sci-mathematics/spin/ChangeLog
index 6432b8eb02d9..a7792b253a24 100644
--- a/sci-mathematics/spin/ChangeLog
+++ b/sci-mathematics/spin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/spin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.2 2010/06/11 14:31:38 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.3 2010/06/22 17:49:59 phajdan.jr Exp $
+
+*spin-5.2.5-r1 (22 Jun 2010)
+
+ 22 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +spin-5.2.5-r1.ebuild, +files/spin-font-size.patch:
+ Apply a patch to make the font size more sane. Otherwise the toolbar
+ buttons are not visible in default configuration.
*spin-5.2.5 (11 Jun 2010)
diff --git a/sci-mathematics/spin/files/spin-font-size.patch b/sci-mathematics/spin/files/spin-font-size.patch
new file mode 100644
index 000000000000..25ba5f08bd25
--- /dev/null
+++ b/sci-mathematics/spin/files/spin-font-size.patch
@@ -0,0 +1,47 @@
+--- xspin.tcl.orig 2010-06-11 16:29:55.000000000 +0200
++++ xspin.tcl 2010-06-22 19:43:37.000000000 +0200
+@@ -82,7 +82,7 @@
+
+ #-- GUI configuration options - by Leszek Holenderski <lhol@win.tue.nl>
+ #-- basic text size:
+- set HelvBig -Adobe-Helvetica-Medium-R-Normal--*-120-*-*-*-*-*-*
++ set HelvBig -Adobe-Helvetica-Medium-R-Normal--*-80-*-*-*-*-*-*
+ # mscs:
+ if {$NT} { ;# on a windows nt machine
+ set SmallFont "-*-Courier-Bold-R-Normal--*-110-*"
+@@ -157,7 +157,7 @@
+ #--- fonts
+ # fonts for the input/log area (default is system dependent,
+ # usually -*-Courier-Medium-R-Normal--*-120-*)
+-option add *Input*Text.font -*-Helvetica-Medium-R-Normal--*-120-* startupFile
++option add *Input*Text.font -*-Helvetica-Medium-R-Normal--*-80-* startupFile
+ #option add *Input*Text.font -schumacher-clean-medium-r-normal--*-120-*-60-* startupFile
+ #option add *Log*Text.font -schumacher-clean-medium-r-normal--*-120-*-60-* startupFile
+
+@@ -168,7 +168,7 @@
+ option add *SimpleText.Text.background white
+
+ # sections (decorated frames for grouping related buttons)
+- option add *Section*Title.font -*-Helvetica-Bold-R-Normal--*-100-* startupFile
++ option add *Section*Title.font -*-Helvetica-Bold-R-Normal--*-60-* startupFile
+
+ #option add *Section*Checkbutton.font -*-Helvetica-Medium-R-Normal--*-100-* startupFile
+ #option add *Section*Radiobutton.font -*-Helvetica-Medium-R-Normal--*-100-* startupFile
+@@ -480,7 +480,7 @@
+ .menu.edit.m add command -label "Paste" \
+ -command {tk_textPaste .inp.t}
+
+-set FSz 110
++set FSz 80
+
+ menu .menu.view.m
+ .menu.view.m add command -label "Larger" \
+@@ -491,7 +491,7 @@
+ }
+ .menu.view.m add command -label "Default text size" \
+ -command {
+- set FSz 110
++ set FSz 80
+ set HelvBig "-Adobe-Helvetica-Medium-R-Normal--*-$FSz-*-*-*-*-*-*"
+ .inp.t configure -font $HelvBig
+ }
diff --git a/sci-mathematics/spin/spin-5.2.5-r1.ebuild b/sci-mathematics/spin/spin-5.2.5-r1.ebuild
new file mode 100644
index 000000000000..daa3c56d7dd3
--- /dev/null
+++ b/sci-mathematics/spin/spin-5.2.5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/spin-5.2.5-r1.ebuild,v 1.1 2010/06/22 17:49:59 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PV=$(replace_all_version_separators '')
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="Tool for formal verification of distributed software systems."
+HOMEPAGE="http://spinroot.com/"
+SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz
+ http://spinroot.com/spin/Src/xspin525.tcl"
+
+LICENSE="|| ( spin-commercial spin-educational )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="graphviz tk"
+
+DEPEND="sys-devel/bison"
+RDEPEND="sys-devel/gcc
+ sys-process/time
+ tk? (
+ dev-lang/tk
+ graphviz? ( media-gfx/graphviz )
+ )"
+
+S="${WORKDIR}/Spin/Src${PV}"
+
+src_unpack() {
+ unpack "${MY_P}.tar.gz"
+ cp "${DISTDIR}/xspin525.tcl" "${S}/xspin.tcl" || die "cp failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+ epatch "${FILESDIR}/${PN}-xspin-r1.patch"
+ epatch "${FILESDIR}/${PN}-font-size.patch"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dobin spin || die "dobin failed"
+ doman ../Man/spin.1 || die "doman failed"
+ dodoc ../Doc/* || die "dodoc failed"
+ if use tk; then
+ newbin xspin.tcl xspin || die "newbin failed"
+ make_desktop_entry xspin XSpin
+ fi
+}