summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cgal/cgal-3.3.1.ebuild')
-rw-r--r--sci-mathematics/cgal/cgal-3.3.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-mathematics/cgal/cgal-3.3.1.ebuild b/sci-mathematics/cgal/cgal-3.3.1.ebuild
index 0b8bbc34ec55..6ee20eaf9e79 100644
--- a/sci-mathematics/cgal/cgal-3.3.1.ebuild
+++ b/sci-mathematics/cgal/cgal-3.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-3.3.1.ebuild,v 1.2 2008/11/17 10:13:00 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-3.3.1.ebuild,v 1.3 2009/08/12 20:27:00 bicatali Exp $
EAPI=2
@@ -35,9 +35,9 @@ src_prepare() {
# a patch from debian on missing qt headers
epatch "${FILESDIR}"/${P}-qt.patch
# sed for blas and lapack gentoo style
- sed -e 's/Intel MKL/Gentoo BLAS-LAPACK/' \
- -e "s/^LIBS.=.*/LIBS=$(pkg-config --libs-only-l lapack | sed 's/-l//g')/" \
- -e "s/^STDLIBDIRS.=*/STDLIBDIRS=$(pkg-config --libs-only-L lapack | sed 's/-L//g')/" \
+ sed -e 's:Intel MKL:Gentoo BLAS-LAPACK:' \
+ -e "s:^LIBS.=.*:LIBS=$(pkg-config --libs-only-l lapack | sed 's/-l//g'):" \
+ -e "s:^STDLIBDIRS.=*:STDLIBDIRS=$(pkg-config --libs-only-L lapack | sed 's/-L//g'):" \
config/support/S48a-MKL64 \
> config/support/S48e-GENTOOLAPACK || die
sed -i -e 's/-O2//' install_cgal || die