summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/xdrawchem/xdrawchem-1.9.5.ebuild')
-rw-r--r--sci-chemistry/xdrawchem/xdrawchem-1.9.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-chemistry/xdrawchem/xdrawchem-1.9.5.ebuild b/sci-chemistry/xdrawchem/xdrawchem-1.9.5.ebuild
new file mode 100644
index 000000000000..a2cb0e46809c
--- /dev/null
+++ b/sci-chemistry/xdrawchem/xdrawchem-1.9.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdrawchem/xdrawchem-1.9.5.ebuild,v 1.1 2005/05/06 07:25:50 phosphan Exp $
+
+DESCRIPTION="Molecular structure drawing program"
+HOMEPAGE="http://xdrawchem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3.1.0
+ >=sys-devel/gcc-3.2
+ dev-util/pkgconfig
+ >=sci-chemistry/openbabel-1.100.2"
+
+src_compile() {
+ # make sure we use moc from Qt, not from eg media-sound/moc
+ PATH="${QTDIR}/bin:${PATH}"
+ econf || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed."
+ cd ${D}/usr/share
+ dodir /usr/share/doc
+ mv xdrawchem/doc doc/${PF}
+ dosym /usr/share/doc/${PF} /usr/share/xdrawchem/doc
+}