summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/ball/files/ball-1.4.1-pthread.patch')
-rw-r--r--sci-chemistry/ball/files/ball-1.4.1-pthread.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sci-chemistry/ball/files/ball-1.4.1-pthread.patch b/sci-chemistry/ball/files/ball-1.4.1-pthread.patch
new file mode 100644
index 000000000000..5ca9699dc7bd
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.1-pthread.patch
@@ -0,0 +1,19 @@
+ CMakeLists.txt | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a68497f..264f321 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -426,6 +426,11 @@ LIST(APPEND BALL_DEP_LIBRARIES
+ ${PYTHON_LIBRARIES}
+ )
+
++
++IF(UNIX)
++ LIST(APPEND BALL_DEP_LIBRARIES "pthread")
++ENDIF()
++
+ IF(TBB_FOUND)
+ LIST(APPEND BALL_DEP_LIBRARIES ${TBB_LIBRARIES})
+ ENDIF()