summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/biopython/files/biopython-1.47-kdtree.patch')
-rw-r--r--sci-biology/biopython/files/biopython-1.47-kdtree.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/biopython/files/biopython-1.47-kdtree.patch b/sci-biology/biopython/files/biopython-1.47-kdtree.patch
new file mode 100644
index 000000000000..5d9563f2dc0c
--- /dev/null
+++ b/sci-biology/biopython/files/biopython-1.47-kdtree.patch
@@ -0,0 +1,43 @@
+--- setup.py.old 2007-03-17 15:21:04.000000000 -0400
++++ setup.py 2007-05-17 14:02:42.000000000 -0400
+@@ -64,6 +64,7 @@
+ _CHECKED = check_dependencies()
+ return _CHECKED
+
++USE_KDTREE = False
+ def check_dependencies():
+ """Return whether the installation should continue."""
+ # There should be some way for the user to tell specify not to
+@@ -112,15 +113,8 @@
+
+
+ # Compile KDTree ? Not compiled by default
+- print "\n*** Bio.KDTree *** NOT built by default "
+- kdtree_msg = """
+-The Bio.PDB.NeighborSearch module depends on the Bio.KDTree module,
+-which in turn, depends on C++ code that does not compile cleanly on
+-all platforms. Hence, Bio.KDTree is not built by default.
+-
+-Would you like to build Bio.KDTree ?"""
+-
+- if get_yes_or_no (kdtree_msg, 0):
++ global USE_KDTREE
++ if USE_KDTREE:
+ NUMPY_PACKAGES.append("Bio.KDTree")
+ NUMPY_EXTENSIONS.append(
+ CplusplusExtension('Bio.KDTree._CKDTree',
+--- Tests/test_KDTree.py.old 2008-07-05 16:32:25.000000000 -0400
++++ Tests/test_KDTree.py 2008-07-05 16:41:33.000000000 -0400
+@@ -1,4 +1,11 @@
+-from Bio.KDTree.KDTree import _neighbor_test, _test
++from Bio import MissingExternalDependencyError
++
++try:
++ from Bio.KDTree.KDTree import _neighbor_test, _test
++except ImportError:
++ message = 'Could not import KDTree module ' \
++ '(not important if you do not plan to use BIO.KDTree).'
++ raise MissingExternalDependencyError(message)
+
+ nr_points=5000
+ dim=3