summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/aaindex')
-rw-r--r--sci-biology/aaindex/ChangeLog5
-rw-r--r--sci-biology/aaindex/aaindex-6.0.ebuild18
2 files changed, 15 insertions, 8 deletions
diff --git a/sci-biology/aaindex/ChangeLog b/sci-biology/aaindex/ChangeLog
index 83ec934591c1..8e8044e0e6f3 100644
--- a/sci-biology/aaindex/ChangeLog
+++ b/sci-biology/aaindex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/aaindex
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/ChangeLog,v 1.3 2005/01/14 22:47:33 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/ChangeLog,v 1.4 2005/02/23 03:59:50 ribosome Exp $
+
+ 22 Feb 2005; Olivier Fisette <ribosome@gentoo.org> aaindex-6.0.ebuild:
+ Added support for the "emboss" and "minimal" "USE" flags.
14 Jan 2005; Lina Pezzella <j4rg0n@gentoo.org> aaindex-6.0.ebuild:
Stable ppc-macos.
diff --git a/sci-biology/aaindex/aaindex-6.0.ebuild b/sci-biology/aaindex/aaindex-6.0.ebuild
index 5bd319ddde9c..62e5995d2f45 100644
--- a/sci-biology/aaindex/aaindex-6.0.ebuild
+++ b/sci-biology/aaindex/aaindex-6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/aaindex-6.0.ebuild,v 1.3 2005/01/14 22:47:33 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/aaindex/aaindex-6.0.ebuild,v 1.4 2005/02/23 03:59:50 ribosome Exp $
DESCRIPTION="Amino acid indices and similarity matrices"
HOMEPAGE="http://www.genome.ad.jp/aaindex"
@@ -12,32 +12,36 @@ SRC_URI="ftp://ftp.genome.ad.jp/pub/db/genomenet/${PN}/${PN}.doc
LICENSE="public-domain"
SLOT="0"
KEYWORDS="x86 ~ppc ppc-macos"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
S=${WORKDIR}
src_unpack() {
+ echo
einfo "No archive to unpack."
+ echo
}
src_compile() {
- # Index the database for use with emboss if emboss is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/aaindexextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir AAINDEX
+ echo
einfo "Indexing AAindex for usage with EMBOSS."
EMBOSS_DATA=. aaindexextract -auto -infile ${DISTDIR}/${PN}1 || die \
"Indexing AAindex failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${DISTDIR}/{${PN}{1,2},list_of_{matrices,indices}}
fi
dodoc ${DISTDIR}/${PN}.doc
- if [ -e /usr/bin/aaindexextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/AAINDEX
doins AAINDEX/*
fi