summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zodb/zodb-3.10.1.ebuild')
-rw-r--r--net-zope/zodb/zodb-3.10.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-zope/zodb/zodb-3.10.1.ebuild b/net-zope/zodb/zodb-3.10.1.ebuild
new file mode 100644
index 000000000000..1656d42a141c
--- /dev/null
+++ b/net-zope/zodb/zodb-3.10.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zodb/zodb-3.10.1.ebuild,v 1.1 2010/10/30 04:53:26 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="ZODB3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Object DataBase"
+HOMEPAGE="http://pypi.python.org/pypi/ZODB3 https://launchpad.net/zodb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/manuel
+ >=net-zope/transaction-1.1.0
+ net-zope/zc-lockfile
+ net-zope/zconfig
+ net-zope/zdaemon
+ net-zope/zope-event
+ net-zope/zope-interface
+ net-zope/zope-testing
+ !media-libs/FusionSound"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="doc/* HISTORY.txt README.txt"
+PYTHON_MODNAME="BTrees persistent ZEO ZODB"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 src
+}
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}